summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Kohlmeyer2018-03-22 16:18:23 +0100
committerSimon Kohlmeyer2018-03-22 16:18:23 +0100
commit9ece9150ac4c84deacc435b1481c1d7154b07c44 (patch)
tree6f5066c69573f2da7bcbe02a59e0a3a943339ce7
parent0faa5ac56603d9b4bbc5bff81648ddf5d84ae1ff (diff)
downloadaur-9ece9150ac4c84deacc435b1481c1d7154b07c44.tar.gz
Properly install license and avoid empty dir
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d798ea62506b..65f527a8b9bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgver=1.3.7
pkgrel=1
pkgdesc="heads up display for the command line that will show git information"
url="http://hackage.haskell.org/package/$_hkgname"
-license=("BSD3")
+license=("BSD")
arch=('x86_64')
depends=('ghc' 'ghc-libs' 'haskell-mtl' 'haskell-parsec' 'haskell-text' 'haskell-unix' 'haskell-process')
makedepends=('ghc')
@@ -18,7 +18,7 @@ build() {
cd "$srcdir/$_hkgname-$pkgver"
runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
- --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
+ --prefix=/usr \
--dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
-fcurl -fpkgconfig -f-static -fterminfo -fthreaded -fexecutable \
-f-rts -foptimize -f-warn-as-error -f-libiconv
@@ -34,6 +34,7 @@ package() {
install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
runhaskell Setup copy --destdir="${pkgdir}"
# The generated binary is called gitHUD, but it's probably convenient to be able to call it