summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Kohlmeyer2018-04-03 12:40:02 +0200
committerSimon Kohlmeyer2018-04-03 12:40:02 +0200
commitdae1b03f727704701d551549353e875e00604987 (patch)
tree5a77bf12796abcf553d225ab63f475e67a4a6dac
parent4c8e9164d6892ef615bb73822551e72c5958a70e (diff)
downloadaur-dae1b03f727704701d551549353e875e00604987.tar.gz
v2.0.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4532973bc54..0adce9bf7862 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Mar 22 15:23:47 UTC 2018
+# Tue Apr 3 10:38:55 UTC 2018
pkgbase = githud
pkgdesc = heads up display for the command line that will show git information
- pkgver = 1.3.7
+ pkgver = 2.0.1
pkgrel = 1
url = https://github.com/gbataille/gitHUD
arch = x86_64
@@ -15,8 +15,8 @@ pkgbase = githud
depends = haskell-text
depends = haskell-unix
depends = haskell-process
- source = http://hackage.haskell.org/packages/archive/gitHUD/1.3.7/gitHUD-1.3.7.tar.gz
- sha256sums = dc38431b13d2dc4625987131c1389ed4ab67154990035c0c66f30d90d1a344af
+ source = http://hackage.haskell.org/packages/archive/githud/2.0.1/githud-2.0.1.tar.gz
+ sha256sums = 9096896544fa98b344dad27c856ab62fa691a9afe78dbdbb3834567d5b28ac62
pkgname = githud
diff --git a/PKGBUILD b/PKGBUILD
index 6abbefab904b..0a0ba1946946 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# $Id$
# Maintainer: Simon Kohlmeyer <simon.kohlmeyer@gmail.com>
-_hkgname=gitHUD
-pkgname=githud
-pkgver=1.3.7
+_hkgname=githud
+pkgname=$_hkgname
+pkgver=2.0.1
pkgrel=1
pkgdesc="heads up display for the command line that will show git information"
url="https://github.com/gbataille/gitHUD"
@@ -12,7 +12,7 @@ arch=('x86_64')
depends=('ghc' 'ghc-libs' 'haskell-mtl' 'haskell-parsec' 'haskell-text' 'haskell-unix' 'haskell-process')
makedepends=('ghc')
source=(http://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz)
-sha256sums=('dc38431b13d2dc4625987131c1389ed4ab67154990035c0c66f30d90d1a344af')
+sha256sums=('9096896544fa98b344dad27c856ab62fa691a9afe78dbdbb3834567d5b28ac62')
build() {
cd "$srcdir/$_hkgname-$pkgver"
@@ -37,9 +37,5 @@ package() {
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
runhaskell Setup copy --destdir="${pkgdir}"
- # The generated binary is called gitHUD, but it's probably convenient to be able to call it
- # githud instead
- ln -s gitHUD "${pkgdir}/usr/bin/githud"
-
rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
}