summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAriel Abreu2020-06-10 00:00:34 -0400
committerAriel Abreu2020-06-10 00:00:34 -0400
commit8f0bb38959497bef0e61445a0a4411b9fab4ab3d (patch)
tree79ebd2c3bb7ba00abed711f2b9f1b46c563c5f0e
downloadaur-8f0bb38959497bef0e61445a0a4411b9fab4ab3d.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD32
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b696d203a9c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = gitify-bin
+ pkgdesc = GitHub notifications on your menu bar
+ pkgver = 3.0.5
+ pkgrel = 1
+ url = https://www.gitify.io/
+ arch = x86_64
+ license = MIT
+ depends = gtk3
+ depends = libnotify
+ depends = nss
+ depends = libxss
+ depends = libxtst
+ depends = xdg-utils
+ depends = at-spi2-core
+ depends = libutil-linux
+ depends = libappindicator-gtk3
+ depends = libsecret
+ noextract = gitify-bin-3.0.5.deb
+ options = !strip
+ source = gitify-bin-3.0.5.deb::https://github.com/manosim/gitify/releases/download/v3.0.5/gitify_3.0.5_amd64.deb
+ source = LICENSE::https://raw.githubusercontent.com/manosim/gitify/v3.0.5/LICENSE
+ sha256sums = 32cc787606a2c25e00cd6f73a3a9de6826afb6d4dd3618da355c264d075794d7
+ sha256sums = SKIP
+
+pkgname = gitify-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0e4ec007016
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Ariel Abreu <facekapow@outlook.com>
+
+pkgname='gitify-bin'
+pkgver='3.0.5'
+pkgrel=1
+pkgdesc='GitHub notifications on your menu bar'
+arch=('x86_64')
+url='https://www.gitify.io/'
+license=('MIT')
+depends=('gtk3' 'libnotify' 'nss' 'libxss' 'libxtst' 'xdg-utils' 'at-spi2-core' 'libutil-linux' 'libappindicator-gtk3' 'libsecret')
+source=(
+ "$pkgname-$pkgver.deb::https://github.com/manosim/gitify/releases/download/v$pkgver/gitify_${pkgver}_amd64.deb"
+ "LICENSE::https://raw.githubusercontent.com/manosim/gitify/v$pkgver/LICENSE"
+)
+sha256sums=(
+ '32cc787606a2c25e00cd6f73a3a9de6826afb6d4dd3618da355c264d075794d7'
+ 'SKIP'
+)
+noextract=("$pkgname-$pkgver.deb")
+options=('!strip')
+
+package() {
+ cd "$pkgdir"
+
+ ar p "$srcdir/$pkgname-$pkgver.deb" data.tar.xz | tar xJ
+
+ install -d -m755 "${pkgdir}/usr/bin"
+ ln -s /opt/Gitify/gitify "${pkgdir}/usr/bin"
+
+ install -d -m755 "${pkgdir}/usr/share/licenses/gitify-bin"
+ install -m644 "$srcdir/LICENSE" "${pkgdir}/usr/share/licenses/gitify-bin/LICENSE"
+}