summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Dewar2018-04-21 09:54:38 +0100
committerAlex Dewar2018-04-21 09:54:38 +0100
commit43effcd51fd5b26f0c293022263fa11db9c637c5 (patch)
tree46e53b7e8781c01be4636bd2652be661e656ace5
downloadaur-43effcd51fd5b26f0c293022263fa11db9c637c5.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD27
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef7923f223ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = gitignore-git
+ pkgdesc = GitHub's useful collection of .gitignore templates
+ pkgver = r2763.4b37ac26
+ pkgrel = 1
+ url = https://github.com/github/gitignore
+ arch = any
+ license = custom:CC0-1.0
+ source = git+https://github.com/github/gitignore
+ md5sums = SKIP
+
+pkgname = gitignore-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b8305d0126a7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+gitignore/
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..764b45768917
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alex Dewar <a.dewar@sussex.ac.uk>
+pkgname=gitignore-git
+pkgver=r2763.4b37ac26
+pkgrel=1
+pkgdesc="GitHub's useful collection of .gitignore templates"
+arch=("any")
+url="https://github.com/github/gitignore"
+license=('custom:CC0-1.0')
+source=("git+$url")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/gitignore"
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -d "$pkgdir"/opt/gitignore
+ cp -r "$srcdir"/gitignore/* "$pkgdir"/opt/gitignore
+
+ install -d "$pkgdir"/usr/share/doc/$pkgname
+ ln -s /opt/gitignore/README.md "$pkgdir"/usr/share/doc/$pkgname
+
+ install -d "$pkgdir"/usr/share/licenses/$pkgname
+ ln -s /opt/gitignore/LICENSE "$pkgdir"/usr/share/licenses/$pkgname
+}