summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-07-27 09:24:14 -0600
committerMark Wagie2020-07-27 09:24:14 -0600
commit258703b9963dc9edfc6cb8813ab1bcf51fb34f2a (patch)
treeadaa50a0310decc1415eff2612cf159f8fb05aab
parent0289784ec74e5ec5cb8c4cfa196d709c92dd1ba7 (diff)
downloadaur-258703b9963dc9edfc6cb8813ab1bcf51fb34f2a.tar.gz
fix typo, minor adjustments
-rw-r--r--PKGBUILD10
1 files changed, 2 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aaa05f27e2ce..cec82d257fdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,9 +15,6 @@ sha256sums=('65bc6f56ef9c8527763ef72d4a334238dbcb60ce2962c319af169236f136b39e'
'8313873d49dc01e8b880ec334d7430ae67496a89aaa8c6e7bbd3affb47a00c76')
prepare() {
- # Prevent creation of a `go` directory in one's home.
- # Sometimes this directory cannot be removed with even `rm -rf` unless
- # one becomes root or changes the write permissions.
export GOPATH="$srcdir/gopath"
go clean -modcache
@@ -30,7 +27,7 @@ prepare() {
}
build() {
- cd "$GOPATH/src/libgit2-$_lg2ver/build"
+ cd "$GOPATH/src/libgit2-$_lg2ver"
cmake -B build -S . \
-DTHREADSAFE=ON \
-DBUILD_CLAR=OFF \
@@ -44,10 +41,7 @@ build() {
-mod=readonly \
-modcacherw \
-ldflags "-extldflags \"${LDFLAGS}\"" \
- -o "$pkgname"
-
- # Clean now to ensure makepkg --clean works
- go clean -modcache
+ -v -o "$pkgname"
}
package() {