summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-09-20 20:36:37 -0600
committeryochananmarqos2019-09-20 20:36:37 -0600
commitd53cb75f5f7daf13d06869ad349d7955428fd169 (patch)
treee69cca674b09aa81e0d6c49f8af61a6ffd459418
parentda188350c1f4152b941ba2fda0661323993bbe84 (diff)
downloadaur-d53cb75f5f7daf13d06869ad349d7955428fd169.tar.gz
updated to 0.2.3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD46
2 files changed, 39 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 863fb1478571..adc55f6cebca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = gitin
pkgdesc = Commit/branch/workdir explorer for git
- pkgver = 0.2.1
+ pkgver = 0.2.3
pkgrel = 1
url = https://github.com/isacikgoz/gitin
arch = x86_64
license = BSD
- makedepends = go
+ makedepends = go-pie
makedepends = git
- depends = libgit2
- source = gitin-0.2.1.tar.gz::https://github.com/isacikgoz/gitin/archive/v0.2.1.tar.gz
- sha256sums = 1a94182b808e72bab32e12b6023c530e7e9a0aeecb7f0b09ca380fa29f7bfe0a
+ makedepends = cmake
+ depends = libgit2=1:0.27.8
+ source = gitin-0.2.3.tar.gz::https://github.com/isacikgoz/gitin/archive/v0.2.3.tar.gz
+ source = libgit2-0.27.0.tar.gz::https://github.com/libgit2/libgit2/archive/v0.27.0.tar.gz
+ sha256sums = 65bc6f56ef9c8527763ef72d4a334238dbcb60ce2962c319af169236f136b39e
+ sha256sums = 545b0458292c786aba334f1bf1c8f73600ae73dd7205a7bb791a187ee48ab8d2
pkgname = gitin
diff --git a/PKGBUILD b/PKGBUILD
index 8d5d91daa6bc..631d9f9ec304 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,48 @@
# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
pkgname=gitin
-pkgver=0.2.1
+pkgver=0.2.3
pkgrel=1
pkgdesc="Commit/branch/workdir explorer for git"
arch=('x86_64')
-url="https://github.com/isacikgoz/$pkgname"
+url="https://github.com/isacikgoz/gitin"
license=('BSD')
-depends=('libgit2')
-makedepends=('go' 'git')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/isacikgoz/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('1a94182b808e72bab32e12b6023c530e7e9a0aeecb7f0b09ca380fa29f7bfe0a')
+depends=('libgit2=1:0.27.8')
+makedepends=('go-pie' 'git' 'cmake')
+_lg2ver=0.27.0
+source=("$pkgname-$pkgver.tar.gz::https://github.com/isacikgoz/$pkgname/archive/v$pkgver.tar.gz"
+ "libgit2-$_lg2ver.tar.gz::https://github.com/libgit2/libgit2/archive/v$_lg2ver.tar.gz")
+sha256sums=('65bc6f56ef9c8527763ef72d4a334238dbcb60ce2962c319af169236f136b39e'
+ '545b0458292c786aba334f1bf1c8f73600ae73dd7205a7bb791a187ee48ab8d2')
prepare() {
export GOPATH="$srcdir/go"
mkdir -p "$GOPATH/src"
-
- if [[ ! -e "$GOPATH/src/$pkgname-$pkgver" ]]; then
- ln -s "$srcdir/$pkgname-$pkgver" "$GOPATH/src/$pkgname-$pkgver"
- fi
+ ln -s "$srcdir/libgit2-$_lg2ver" "$GOPATH/src/libgit2-$_lg2verr"
+ ln -s "$srcdir/$pkgname-$pkgver" "$GOPATH/src/$pkgname-$pkgver"
+
+ cd "$GOPATH/src/libgit2-$_lg2verr"
+ git submodule update --init
}
build() {
- cd $GOPATH
- go get github.com/isacikgoz/gitin
+ export GOPATH="$srcdir/go"
+ cd "$GOPATH/src/libgit2-$_lg2verr"
+ mkdir build && cd build
+ cmake \
+ -DTHREADSAFE=ON \
+ -DBUILD_CLAR=OFF \
+ -DCMAKE_BUILD_TYPE="RelWithDebInfo" ..
+ make
+
+ cd "$GOPATH/src/$pkgname-$pkgver"
+ go build \
+ -trimpath \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o $pkgname
}
package() {
- cd $pkgname-$pkgver
- install -Dm755 $GOPATH/bin/$pkgname $pkgdir/usr/bin/$pkgname
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$GOPATH/src/$pkgname-$pkgver"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}