summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Lipp2016-05-30 22:58:22 +0200
committerMoritz Lipp2016-05-30 22:58:22 +0200
commitd22f8e85fbccd794547e3893aa1492fe69950b35 (patch)
tree2a9ef6158f5eeb9be42a93fe33c56fa0ffde4476
downloadaur-gitinspector-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e15f89783c5f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon May 30 20:58:18 UTC 2016
+pkgbase = gitinspector-git
+ pkgdesc = The statistical analysis tool for git repositories.
+ pkgver = v0.4.2.78.ge543eea
+ pkgrel = 1
+ url = http://code.google.com/p/gitinspector/
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python2
+ conflicts = gitinspector
+ options = !emptydirs
+ source = gitinspector::git+https://github.com/ejwa/gitinspector
+ md5sums = SKIP
+
+pkgname = gitinspector-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3beca246fc5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Moritz Lipp <mlq@pwmt.org>
+pkgname=gitinspector-git
+pkgver=v0.4.2.78.ge543eea
+pkgrel=1
+pkgdesc="The statistical analysis tool for git repositories."
+arch=('any')
+url="http://code.google.com/p/gitinspector/"
+license=('GPL')
+depends=('python2')
+conflicts=('gitinspector')
+makedepends=('git')
+options=(!emptydirs)
+source=('gitinspector::git+https://github.com/ejwa/gitinspector')
+md5sums=('SKIP')
+_gitname=gitinspector
+
+package() {
+ cd "$_gitname"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+pkgver() {
+ cd "$_gitname"
+ local ver="$(git describe --long --tags)"
+ printf "%s" "${ver//-/.}"
+}
+
+# vim:set ts=2 sw=2 et: