summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhil Ruffwind2018-12-20 23:37:14 -0800
committerPhil Ruffwind2018-12-21 02:31:25 -0800
commit7e24627c610873859e5de010cbc111deec0953f6 (patch)
treeec82c3e7847123ea89de5b1adc13684f60ebcfc6
parent63624c8736afca3149bf29ac81d714e03dbfe607 (diff)
downloadaur-7e24627c610873859e5de010cbc111deec0953f6.tar.gz
Use GHC 8.4.4 to compile gitit as temporary workaround
gitit is not yet compatible with GHC 8.6 yet. While that is being fixed, this is a temporary workaround.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 632ba2dec922..55635a779823 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = gitit
pkgdesc = A wiki backed by a git, darcs, or mercurial filestore
pkgver = 0.12.3
- pkgrel = 1
+ pkgrel = 2
url = https://hackage.haskell.org/package/gitit
arch = i686
arch = x86_64
license = GPL
makedepends = cabal-install
- makedepends = ghc-pristine
- makedepends = ghc-static
depends = libffi
depends = gmp
depends = mailcap
+ depends = ncurses5-compat-libs
+ depends = numactl
depends = zlib
optdepends = git: git support
optdepends = mercurial: mercurial support
@@ -369,6 +369,7 @@ pkgbase = gitit
source = haskell-xss-sanitize-0.3.6.tar.gz::https://hackage.haskell.org/package/xss-sanitize-0.3.6/xss-sanitize-0.3.6.tar.gz
source = haskell-zip-archive-0.3.3.tar.gz::https://hackage.haskell.org/package/zip-archive-0.3.3/zip-archive-0.3.3.tar.gz
source = haskell-zlib-0.6.2.tar.gz::https://hackage.haskell.org/package/zlib-0.6.2/zlib-0.6.2.tar.gz
+ source = https://downloads.haskell.org/~ghc/8.4.4/ghc-8.4.4-x86_64-deb9-linux.tar.xz
sha256sums = ae087b359ff2945a62b671449227e0a811d143ee651179f4e7e9c66548e0f514
sha256sums = 77b7daec5a79ade779706748f11b4d9b8f805e57a68e7406c3b5a1dee16e0c2f
sha256sums = 3a77853eba3700c5346cd6d4008302e70dca93a7e8ac0d679cf41b16c7a4c9e8
@@ -546,6 +547,7 @@ pkgbase = gitit
sha256sums = b385eea5652c798b701c627dce8b327c3d6cbfd8c92e1e18e7118862d4d0e2b4
sha256sums = 988adee77c806e0b497929b24d5526ea68bd3297427da0d0b30b99c094efc84d
sha256sums = 0dcc7d925769bdbeb323f83b66884101084167501f11d74d21eb9bc515707fed
+ sha256sums = 47c80a32d8f02838a2401414c94ba260d1fe82b7d090479994522242c767cc83
pkgname = gitit
diff --git a/PKGBUILD b/PKGBUILD
index c5e52a90850a..88264dde4a13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Phil Ruffwind <rf@rufflewind.com>
pkgname=gitit
pkgver=0.12.3
-pkgrel=1
+pkgrel=2
pkgdesc="A wiki backed by a git, darcs, or mercurial filestore"
arch=(i686 x86_64)
url=https://hackage.haskell.org/package/gitit
license=(GPL)
-depends=(libffi gmp mailcap zlib)
+depends=(libffi gmp mailcap ncurses5-compat-libs numactl zlib)
optdepends=("git: git support" "mercurial: mercurial support")
-makedepends=(cabal-install ghc-pristine ghc-static)
+makedepends=(cabal-install)
source=(haskell-ConfigFile-1.1.4.tar.gz::https://hackage.haskell.org/package/ConfigFile-1.1.4/ConfigFile-1.1.4.tar.gz
haskell-Diff-0.3.4.tar.gz::https://hackage.haskell.org/package/Diff-0.3.4/Diff-0.3.4.tar.gz
haskell-Glob-0.9.3.tar.gz::https://hackage.haskell.org/package/Glob-0.9.3/Glob-0.9.3.tar.gz
@@ -362,14 +362,21 @@ sha256sums=('ae087b359ff2945a62b671449227e0a811d143ee651179f4e7e9c66548e0f514'
'9937d440072552c03c6d8ad79f61e61467dc28dcd5adeaad81038b9b94eef8c9'
'b385eea5652c798b701c627dce8b327c3d6cbfd8c92e1e18e7118862d4d0e2b4'
'988adee77c806e0b497929b24d5526ea68bd3297427da0d0b30b99c094efc84d'
- '0dcc7d925769bdbeb323f83b66884101084167501f11d74d21eb9bc515707fed')
+ '0dcc7d925769bdbeb323f83b66884101084167501f11d74d21eb9bc515707fed'
+ '47c80a32d8f02838a2401414c94ba260d1fe82b7d090479994522242c767cc83')
noextract=("${source[@]%%::*}")
+source=("${source[@]}" "https://downloads.haskell.org/~ghc/8.4.4/ghc-8.4.4-$CARCH-deb9-linux.tar.xz")
prepare() {
unset CABAL_SANDBOX_CONFIG CABAL_SANDBOX_PACKAGE_PATH GHC_PACKAGE_PATH
+ (
+ cd ghc-8.4.4
+ ./configure --prefix="$srcdir/.local"
+ make install
+ )
mkdir -p .cabal
cat >.cabal/config <<EOF
-with-compiler: /usr/share/ghc-pristine/bin/ghc
+with-compiler: $srcdir/.local/bin/ghc
jobs: \$ncpus
EOF
cabal --config=.cabal/config sandbox init