summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Johnson2021-08-22 14:40:57 -0600
committerDoug Johnson2021-08-22 14:55:17 -0600
commitd44c0349fda72a294329976007b622c3a41f2ebc (patch)
tree38068e27fcc7af4bf5b7d39374843ab46f319e4a
downloadaur-d44c0349fda72a294329976007b622c3a41f2ebc.tar.gz
Initial
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad648fe8cf1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gitlab-ci-local-git
+ pkgdesc = Run gitlab pipelines locally as shell executor or docker executor
+ pkgver = 4.23.0.r0.g2195c19
+ pkgrel = 1
+ url = https://github.com/firecow/gitlab-ci-local
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = sed
+ makedepends = npm
+ makedepends = typescript
+ depends = ts-node
+ source = gitlab-ci-local-git::git+https://github.com/firecow/gitlab-ci-local.git
+ md5sums = SKIP
+
+pkgname = gitlab-ci-local-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49d874c52697
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Doug Johnson <dougvj at dougvj dot net>
+pkgname=gitlab-ci-local-git
+pkgver=4.23.0.r0.g2195c19
+pkgrel=1
+source=('gitlab-ci-local-git::git+https://github.com/firecow/gitlab-ci-local.git')
+md5sums=('SKIP')
+pkgdesc="Run gitlab pipelines locally as shell executor or docker executor"
+arch=('i686' 'x86_64')
+url="https://github.com/firecow/gitlab-ci-local"
+license=('MIT')
+makedepends=('git' 'sed' 'npm' 'typescript')
+depends=('ts-node')
+pkgver() {
+ cd "$pkgname"
+ git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ npm install
+ npm run build
+}
+
+package() {
+ cd "$pkgname"
+ npm run pkg-linux
+ mkdir -p $pkgdir/usr/bin
+ cp ./bin/linux/gitlab-ci-local $pkgdir/usr/bin
+}
+