summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Taboada2018-04-27 13:54:12 -0500
committerMichael Taboada2018-04-27 13:54:12 -0500
commitc8a4c384b290dae9398e3457e68fdf0ea556ca6f (patch)
tree90dc7feee2db0d389c18d77b78e0b4e30bdcb772
parentff7bd4da8cbafc526f8a89fa49876844ffcb601f (diff)
downloadaur-c8a4c384b290dae9398e3457e68fdf0ea556ca6f.tar.gz
Fixed issue if gitlab was installed already which will often be the case since this is from the AUR
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d955914cb8c1..96e5d7d20517 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Apr 26 20:43:37 UTC 2018
+# Fri Apr 27 18:53:20 UTC 2018
pkgbase = gitlab-ee
pkgdesc = Project management and code hosting application
pkgver = 10.7.1
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.com/gitlab-org/gitlab-ee
install = gitlab.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index fe94a600edf2..56c929e8aa31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
_pkgname=gitlab
pkgname=${_pkgname}-ee
pkgver=10.7.1
-pkgrel=2
+pkgrel=3
pkgdesc="Project management and code hosting application"
arch=('x86_64')
url="https://gitlab.com/gitlab-org/gitlab-ee"
@@ -136,12 +136,20 @@ build() {
cp config/resque.yml.example config/resque.yml
sed -i 's/url.*/nope.sock/g' config/resque.yml
+ #we need to get rid of the custom paths in case someone has gitlab already installed.
+ mv config/gitlab.yml config/gitlab.yml.bak
+ # and create default
+ cp config/gitlab.yml.example config/gitlab.yml
+
yarn install --production --pure-lockfile
bundle-2.3 exec rake gitlab:assets:compile RAILS_ENV=production NODE_ENV=production
bundle-2.3 exec rake gettext:compile RAILS_ENV=production
# After building assets, clean this up again
rm config/database.yml config/database.yml.postgresql.orig
mv config/resque.yml.patched config/resque.yml
+
+ #put back the custom .yml
+ mv config/gitlab.yml.bak config/gitlab.yml
}
package() {