summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorty2020-08-10 17:51:36 +0200
committerWorty2020-08-10 17:52:03 +0200
commit7425714c282b4ee2a2d63d895963d5e075b19d63 (patch)
treee5403a02a528b7fe557ae8d250af0c55f5dafa51
parent8e8867a28b2e4f68d168e8d43cb90262ed4ceedc (diff)
downloadaur-7425714c282b4ee2a2d63d895963d5e075b19d63.tar.gz
fix version and build
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d818fe89d2ee..42b6f7fcacf2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gitlab-glab
pkgdesc = GLab is an open source Gitlab Cli tool written in Go to help work seamlessly with Gitlab from the command line.
pkgver = 1.8.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/profclems/glab
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index c6de4a4928d1..b7433f73f06a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gitlab-glab
_realpkgname=glab
pkgver=1.8.1
-pkgrel=1
+pkgrel=2
pkgdesc='GLab is an open source Gitlab Cli tool written in Go to help work seamlessly with Gitlab from the command line.'
arch=('x86_64')
url="https://github.com/profclems/glab"
@@ -25,8 +25,8 @@ build() {
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
- _builddate=$(date -u +%Y-%m-%d)
- go build -o build -trimpath -buildmode=pie -ldflags "-extldflags \"${LDFLAGS}\" -X glab.version=${pkgver} -X glab.build=${_builddate} -s -w" -modcacherw ./cmd/glab/main.go
+ _builddate=$(date -u +%m/%d/%Y)
+ go build -o build -trimpath -buildmode=pie -ldflags "-extldflags \"${LDFLAGS}\" -X main.version=${pkgver} -X main.build=${_builddate} -s -w" -modcacherw ./cmd/glab/main.go
}
package() {