summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2019-08-17 09:02:51 +0000
committerCaleb Maclennan2019-08-17 09:08:27 +0000
commit460418d36cd5f531de948b2fe1d40af126802886 (patch)
treea5a25bef9e404e61151d78bc34156ef74f2e41f4
parentcb7d41cc0f910088660eb876ac0e568145dd300c (diff)
downloadaur-460418d36cd5f531de948b2fe1d40af126802886.tar.gz
Patch to fix go-pie related chroot issues
This patch (proposed upstream and likely to be in the next release) fixes issues with go-pie. Arch systems may have either go or go-pie by default, go works, but go-pie does not allow both the chroot and user switch to drop root permissions. Without this go-pie compiled gitlab-pages would only work if run as root with no uid switching. Note this also solves the previously patched dynamic linking issue, so drops that monkey patch in favor of this one.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad9453792f96..d35a86260c97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gitlab-pages
pkgdesc = GitLab Pages daemon used to serve static websites for GitLab users
pkgver = 1.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/gitlab-org/gitlab-pages
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 3482a81c2b91..69599d3f0069 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Useful: https://gitlab.com/gitlab-org/gitlab-ce/issues/29963
pkgname=gitlab-pages
pkgver=1.7.0
-pkgrel=1
+pkgrel=2
pkgdesc='GitLab Pages daemon used to serve static websites for GitLab users'
url='https://gitlab.com/gitlab-org/gitlab-pages'
license=('MIT')
@@ -20,9 +20,13 @@ sha256sums=('eda36763002b3fe54633c59d384f9840de38c6fc9008eb04cab25ae088d1d8f7'
'ae62235f0fd66eaed7ad74048daf21b92058aba90e40fc2d3e7a684e9883c32e'
'fd8f9b60e2247077ad00765904237b6b1c36b11a952cd3b1ad88e74417b82a96')
+prepare( ){
+ cd "$srcdir/$pkgname-v$pkgver-"*
+ [[ ${pkgver} == "1.7.0" ]] && sed -i -e '12s/FLAGS) \$(IM/FLAGS) --buildmode exe $(IM/' Makefile.build.mk ||:
+}
+
build() {
cd "$srcdir/$pkgname-v$pkgver-"*
- export GO_EXTLINK_ENABLED=0
make
}