summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2021-12-02 18:50:05 +0100
committerKr1ss2021-12-02 18:50:05 +0100
commitde6b50b5117d9c35c7c14a8eade4d267688cd606 (patch)
tree6f68416a61d28e87990958cc8ee530d716b5158e
parent810fefb54e8e59b3a1fd4f7a464cd6073b513a0a (diff)
downloadaur-de6b50b5117d9c35c7c14a8eade4d267688cd606.tar.gz
update: gitleaks 8.0.7-1
upstream release package {bash,zsh,fish}-completion functions
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffe3a788d654..619510b19eef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gitleaks
pkgdesc = Audit Git repos for secrets and keys
- pkgver = 8.0.6
+ pkgver = 8.0.7
pkgrel = 1
url = https://github.com/zricethezav/gitleaks
arch = x86_64
@@ -8,7 +8,7 @@ pkgbase = gitleaks
license = MIT
makedepends = go
depends = glibc
- source = gitleaks-8.0.6.tar.gz::https://github.com/zricethezav/gitleaks/archive/refs/tags/v8.0.6.tar.gz
- b2sums = 24f7e99f00a683f8545761227b348c67b85dc3c4d6f658b4566b19fb772a2e55ee40b3eb407a176091c108c75d42ed49696f34e89c7e2c50be7563435d6a9d3c
+ source = gitleaks-8.0.7.tar.gz::https://github.com/zricethezav/gitleaks/archive/refs/tags/v8.0.7.tar.gz
+ b2sums = b74313fcdd37f98ba4555d1522447decc8092a4535e62ac5f751641d02155f9f0cf197923e5790a80096433b9a14aa9c75198c88e4e4ff8f6de45aa58f8ad7e9
pkgname = gitleaks
diff --git a/PKGBUILD b/PKGBUILD
index f230262d4d90..e7c8dca1e884 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Daniel M. Capella <polycitizen@gmail.com>
pkgname=gitleaks
-pkgver=8.0.6
+pkgver=8.0.7
pkgrel=1
pkgdesc='Audit Git repos for secrets and keys'
url=https://github.com/zricethezav/gitleaks
@@ -11,7 +11,7 @@ license=('MIT')
depends=('glibc')
makedepends=('go')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
-b2sums=('24f7e99f00a683f8545761227b348c67b85dc3c4d6f658b4566b19fb772a2e55ee40b3eb407a176091c108c75d42ed49696f34e89c7e2c50be7563435d6a9d3c')
+b2sums=('b74313fcdd37f98ba4555d1522447decc8092a4535e62ac5f751641d02155f9f0cf197923e5790a80096433b9a14aa9c75198c88e4e4ff8f6de45aa58f8ad7e9')
build() {
cd "$pkgname-$pkgver"
@@ -27,6 +27,12 @@ package() {
cd "$pkgname-$pkgver"
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
install -Dm755 "$pkgname" "$pkgdir"/usr/bin/"$pkgname"
+ ./gitleaks completion bash --no-descriptions |
+ install -Dm644 /dev/stdin "$pkgdir"/usr/share/bash-completion/completions/"$pkgname"
+ ./gitleaks completion zsh --no-descriptions |
+ install -Dm644 /dev/stdin "$pkgdir"/usr/share/zsh/site-functions/_"$pkgname"
+ ./gitleaks completion fish --no-descriptions |
+ install -Dm644 /dev/stdin "$pkgdir"/usr/share/fish/vendor_completions.d/"$pkgname".fish
}
# vim:set ts=2 sw=2 et: