summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2022-10-18 21:05:13 +0200
committerCarl Smedstad2022-10-18 21:05:57 +0200
commit8c0616681f7640e60f1053e2fd72104c22b29fc2 (patch)
treeee9752ad0ab13afe256805535565019bf60ebaa6
parent099ec27299183d2d28c65c9ccef171c0375adc6e (diff)
downloadaur-8c0616681f7640e60f1053e2fd72104c22b29fc2.tar.gz
Release pkgver 2 with completions
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
-rw-r--r--gitlint.install25
3 files changed, 33 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76bbb47aeeef..6b111f248f8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = gitlint
pkgdesc = Git commit message linter
pkgver = 0.17.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jorisroovers/gitlint
+ install = gitlint.install
arch = any
license = MIT
checkdepends = python-pytest
@@ -14,7 +15,9 @@ pkgbase = gitlint
options = !emptydirs
source = gitlint-0.17.0.tar.gz::https://github.com/jorisroovers/gitlint/archive/refs/tags/v0.17.0.tar.gz
source = 0001-Unset-EDITOR-env-var-in-test_run_hook_edit.patch
+ source = gitlint.install
sha256sums = 1c1e895aea22b1ded131a9dc81dd1f37fb064a9f3af7421debd1606ca646196a
sha256sums = ec117041e4ba8a3a46d27e169982129dd08e455501de676d873fce91b1d934cd
+ sha256sums = d7b51415865e6c3802e3440462022e3b2349b1af813b5c2459e62f3c1dd2feb3
pkgname = gitlint
diff --git a/PKGBUILD b/PKGBUILD
index 2265778620c8..201903b79215 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gitlint
pkgver=0.17.0
-pkgrel=1
+pkgrel=2
pkgdesc='Git commit message linter'
arch=('any')
url='https://github.com/jorisroovers/gitlint'
@@ -22,11 +22,14 @@ checkdepends=(
source=(
"$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz"
"0001-Unset-EDITOR-env-var-in-test_run_hook_edit.patch"
+ "gitlint.install"
)
sha256sums=(
'1c1e895aea22b1ded131a9dc81dd1f37fb064a9f3af7421debd1606ca646196a'
'ec117041e4ba8a3a46d27e169982129dd08e455501de676d873fce91b1d934cd'
+ 'd7b51415865e6c3802e3440462022e3b2349b1af813b5c2459e62f3c1dd2feb3'
)
+install=gitlint.install
prepare() {
cd "$pkgname-$pkgver"
diff --git a/gitlint.install b/gitlint.install
new file mode 100644
index 000000000000..9151ca4a7d10
--- /dev/null
+++ b/gitlint.install
@@ -0,0 +1,25 @@
+post_install() {
+ _GITLINT_COMPLETE=bash_source gitlint > gitlint.bash
+ _GITLINT_COMPLETE=fish_source gitlint > gitlint.fish
+ _GITLINT_COMPLETE=zsh_source gitlint > gitlint.zsh
+
+ install -Dm644 gitlint.bash "/usr/share/bash-completion/completions/gitlint"
+ install -Dm644 gitlint.fish "/usr/share/fish/vendor_completions.d/gitlint.fish"
+ install -Dm644 gitlint.zsh "/usr/share/zsh/site-functions/_gitlint"
+}
+
+post_upgrade() {
+ _GITLINT_COMPLETE=bash_source gitlint > gitlint.bash
+ _GITLINT_COMPLETE=fish_source gitlint > gitlint.fish
+ _GITLINT_COMPLETE=zsh_source gitlint > gitlint.zsh
+
+ install -Dm644 gitlint.bash "/usr/share/bash-completion/completions/gitlint"
+ install -Dm644 gitlint.fish "/usr/share/fish/vendor_completions.d/gitlint.fish"
+ install -Dm644 gitlint.zsh "/usr/share/zsh/site-functions/_gitlint"
+}
+
+post_remove() {
+ rm "/usr/share/bash-completion/completions/gitlint"
+ rm "/usr/share/fish/vendor_completions.d/gitlint.fish"
+ rm "/usr/share/zsh/site-functions/_gitlint"
+}