summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-03-16 10:40:59 -0700
committerAndy Weidenbaum2017-03-16 10:40:59 -0700
commitd9f6adb891a07c924906ca329812588b133b2c61 (patch)
treea0087aed7fccd425a68fd7c61b72bff4e0c76aa0
parent75112ef648bf606ad68bdfe9e60ba8bd731faadc (diff)
downloadaur-d9f6adb891a07c924906ca329812588b133b2c61.tar.gz
update pkgver to 0.8.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--requirements.txt.patch16
-rw-r--r--setup.py.patch23
4 files changed, 9 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7561a5c56988..e7eba4e9eb5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Dec 31 16:54:24 UTC 2016
+# Thu Mar 16 17:40:18 UTC 2017
pkgbase = gitlint
pkgdesc = Git commit message linter
- pkgver = 0.8.0
+ pkgver = 0.8.1
pkgrel = 1
url = https://jorisroovers.github.io/gitlint/
arch = any
@@ -14,12 +14,8 @@ pkgbase = gitlint
depends = python-ordereddict
depends = python-sh
options = !emptydirs
- source = gitlint-0.8.0.tar.gz::https://codeload.github.com/jorisroovers/gitlint/tar.gz/v0.8.0
- source = requirements.txt.patch
- source = setup.py.patch
- sha256sums = dbbbc8741fc4f9ede748fdeb8136bdaffe9b2a0bf66e16baf87ebf539c814d98
- sha256sums = e3bb9e56ee1d971f828d5cf3cff1b6293fc5860460670fd5114c6546f74339e4
- sha256sums = 0bff8c9f7849cc16fcc3b124ccdb2fd7af25834372eedd82b381016524b5b368
+ source = gitlint-0.8.1.tar.gz::https://codeload.github.com/jorisroovers/gitlint/tar.gz/v0.8.1
+ sha256sums = 7f2cadaf2179f7f3c265b2c36965d198d77dc3e8101ac6b0b697df59bd930010
pkgname = gitlint
diff --git a/PKGBUILD b/PKGBUILD
index 970705b60c5f..07bcfbc6e633 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
pkgname=gitlint
-pkgver=0.8.0
+pkgver=0.8.1
pkgrel=1
pkgdesc="Git commit message linter"
arch=('any')
@@ -14,19 +14,15 @@ makedepends=('python-setuptools')
url="https://jorisroovers.github.io/gitlint/"
license=('MIT')
options=(!emptydirs)
-source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/jorisroovers/$pkgname/tar.gz/v$pkgver
- requirements.txt.patch
- setup.py.patch)
-sha256sums=('dbbbc8741fc4f9ede748fdeb8136bdaffe9b2a0bf66e16baf87ebf539c814d98'
- 'e3bb9e56ee1d971f828d5cf3cff1b6293fc5860460670fd5114c6546f74339e4'
- '0bff8c9f7849cc16fcc3b124ccdb2fd7af25834372eedd82b381016524b5b368')
+source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/jorisroovers/$pkgname/tar.gz/v$pkgver)
+sha256sums=('7f2cadaf2179f7f3c265b2c36965d198d77dc3e8101ac6b0b697df59bd930010')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
msg2 'Loosening PyPi dependency restrictions...'
- patch -p1 < "$srcdir/requirements.txt.patch"
- patch -p1 < "$srcdir/setup.py.patch"
+ sed -i 's/==1\.11//' requirements.txt setup.py
+ sed -i 's/==6\.6//' setup.py
}
build() {
diff --git a/requirements.txt.patch b/requirements.txt.patch
deleted file mode 100644
index 6539c3739f2d..000000000000
--- a/requirements.txt.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- ./requirements.txt 2016-12-31 08:51:58.490847575 -0800
-+++ ./requirements.txt 2016-12-31 08:52:10.431399210 -0800
-@@ -1,7 +1,6 @@
- setuptools
--wheel==0.24.0
--Click==6.6
--sh==1.11
--arrow==0.10.0
--ordereddict==1.1
--importlib==1.0.3; python_version < '2.7'
-\ No newline at end of file
-+wheel
-+Click
-+sh
-+arrow
-+ordereddict
diff --git a/setup.py.patch b/setup.py.patch
deleted file mode 100644
index 834fc4b62605..000000000000
--- a/setup.py.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- ./setup.py 2016-12-31 08:50:31.153301858 -0800
-+++ ./setup.py 2016-12-31 08:50:43.154796909 -0800
-@@ -57,16 +57,11 @@
- "License :: OSI Approved :: MIT License"
- ],
- install_requires=[
-- 'Click==6.6',
-- 'sh==1.11',
-- 'arrow==0.10.0',
-- 'ordereddict==1.1',
-+ 'Click',
-+ 'sh',
-+ 'arrow',
-+ 'ordereddict',
- ],
-- extras_require={
-- ':python_version == "2.6"': [
-- 'importlib==1.0.3',
-- ],
-- },
- keywords='gitlint git lint',
- author='Joris Roovers',
- url='https://github.com/jorisroovers/gitlint',