summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Hofmann2012-01-24 16:55:43 +0100
committerPeter Hofmann2012-01-24 16:55:43 +0100
commit59fd4ef715f26b9011392008fa58f8f99b493fb6 (patch)
tree85ccfac632c69c8f98bacb1d46ad29cb45caf46d
downloadaur-59fd4ef715f26b9011392008fa58f8f99b493fb6.tar.gz
Initial: Copied all existing PKGBUILDs.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD56
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40149fe25f5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gitodo-git
+ pkgdesc = Manage your TODO items using Git as a backend
+ pkgver = 20111105
+ pkgrel = 1
+ url = http://www.uninformativ.de/projects/?q=gitodo
+ arch = any
+ license = custom:PIZZA-WARE
+ makedepends = git
+ depends = git
+ optdepends = ncurses: Colored output
+ optdepends = cron: Reminder functionality
+ optdepends = python: Overview of your TODO items in `highcal`
+ optdepends = vim: A reasonable editor, syntax files are provided
+
+pkgname = gitodo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a136cd508623
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Vain <aurmaint1 on host: uninformativ dot de>
+pkgname=gitodo-git
+pkgver=20111105
+pkgrel=1
+pkgdesc="Manage your TODO items using Git as a backend"
+arch=('any')
+url='http://www.uninformativ.de/projects/?q=gitodo'
+license=('custom:PIZZA-WARE')
+makedepends=('git')
+depends=('git')
+optdepends=(
+ 'ncurses: Colored output'
+ 'cron: Reminder functionality'
+ 'python: Overview of your TODO items in `highcal`'
+ 'vim: A reasonable editor, syntax files are provided'
+)
+
+_gitroot='git://github.com/vain/gitodo.git'
+_gitname='master'
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+
+ install -Dm755 gitodo "$pkgdir"/usr/bin/gitodo
+ install -Dm755 highcal "$pkgdir"/usr/bin/highcal
+
+ install -Dm644 README.md \
+ "$pkgdir/usr/share/doc/${pkgname%-git}/README.md"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ install -Dm644 vim/ftdetect/gitodo.vim \
+ "$pkgdir"/usr/share/vim/vimfiles/ftdetect/gitodo.vim
+ install -Dm644 vim/syntax/gitodo.vim \
+ "$pkgdir"/usr/share/vim/vimfiles/syntax/gitodo.vim
+}
+
+# vim:set ts=2 sw=2 et: