summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Hofmann2013-04-05 23:27:45 +0200
committerPeter Hofmann2013-04-05 23:45:54 +0200
commitef13f6d3b966405dc050e15d95f96120cdbc0d7d (patch)
tree3f7da3bfe886ea37cd631e8ec16601d99cb667b2
parentf175c59856b3b549528bfd5f4d933dda6a5e2893 (diff)
downloadaur-ef13f6d3b966405dc050e15d95f96120cdbc0d7d.tar.gz
Update all PKGBUILDs for pacman 4.1
As recommended on the ML, I chose not to bump the epoch.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD32
2 files changed, 12 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5061133205e7..b4707e79d5ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gitodo-git
pkgdesc = Manage your TODO items using Git as a backend
- pkgver = 20121205
+ pkgver = 13.01.5.g12160cb
pkgrel = 1
url = http://www.uninformativ.de/projects/?q=gitodo
arch = any
@@ -10,6 +10,8 @@ pkgbase = gitodo-git
depends = ruby
optdepends = cron: Reminder functionality
optdepends = vim: A reasonable editor, syntax files are provided
+ source = git://github.com/vain/gitodo.git
+ md5sums = SKIP
pkgname = gitodo-git
diff --git a/PKGBUILD b/PKGBUILD
index d196eb3a972f..1a2ba0dab0c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Vain <aurmaint1 on host: uninformativ dot de>
-pkgname=gitodo-git
-pkgver=20121205
+_pkgname=gitodo
+pkgname=$_pkgname-git
+pkgver=13.01.5.g12160cb
pkgrel=1
pkgdesc="Manage your TODO items using Git as a backend"
arch=('any')
@@ -12,31 +13,16 @@ optdepends=(
'cron: Reminder functionality'
'vim: A reasonable editor, syntax files are provided'
)
+source=(git://github.com/vain/gitodo.git)
+md5sums=('SKIP')
-_gitroot='git://github.com/vain/gitodo.git'
-_gitname='master'
-
-build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed 's|-|.|g; s|v||'
}
package() {
- cd "$srcdir/$_gitname-build"
+ cd "$srcdir/$_pkgname"
install -Dm755 gitodo "$pkgdir"/usr/bin/gitodo
install -Dm755 highcal "$pkgdir"/usr/bin/highcal