summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYu-Fu Fu2021-06-03 19:27:31 -0400
committerYu-Fu Fu2021-06-03 19:27:31 -0400
commit7d191908162ae2d0b8debf89edcf394bef41ad8b (patch)
treee2b9dfe97ec3324d3371b4909179890250af4a2c
parentb562326be2d11471d305117ee1d8aaa242dcc546 (diff)
downloadaur-7d191908162ae2d0b8debf89edcf394bef41ad8b.tar.gz
upgpkg: gitql-bin 2.2.0-1
upstream release bump git-ql to 2.2.0
-rw-r--r--.SRCINFO11
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD16
3 files changed, 33 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27d602d3a16a..6e0cd6db2cc7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = gitql-bin
pkgdesc = A git query language
- pkgver = 2.1.0
+ pkgver = 2.2.0
pkgrel = 1
- url = https://github.com/cloudson/gitql
+ url = https://github.com/filhodanuvem/gitql
arch = x86_64
license = MIT
depends = glibc
provides = gitql
- source = gitql-bin-2.1.0.zip::https://github.com/filhodanuvem/gitql/releases/download/2.1.0/gitql-linux64.1.zip
- source = LICENSE::https://github.com/cloudson/gitql/raw/master/LICENSE
- sha256sums = ecdb8bc2dd28a4d216c2ec87d4d94cfeb406657c0c39e6cb6c511dca3ac51fa8
+ source = gitql-bin-2.2.0.zip::https://github.com/filhodanuvem/gitql/releases/download/2.2.0/gitql-linux64.zip
+ source = LICENSE::https://github.com/filhodanuvem/gitql/raw/main/LICENSE
+ sha256sums = 18a73ed06cbac727de7ab4f4ec18bd4f2046b297a06122aac46692e43e3a343a
sha256sums = ca995d876d4738b7f7309c46f443f42bc887db327ed183fe46733a59f06f80b5
pkgname = gitql-bin
-
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..50a08f0417f8
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2014 Claudson Oliveira
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 75335c73ff41..3fead56a1b9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
-# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
-
pkgname=gitql-bin
-pkgver=2.1.0
+pkgver=2.2.0
pkgrel=1
pkgdesc='A git query language'
arch=('x86_64')
-url="https://github.com/cloudson/gitql"
+url="https://github.com/filhodanuvem/gitql"
license=('MIT')
provides=('gitql')
depends=('glibc')
-source=("${pkgname}-${pkgver}.zip::https://github.com/filhodanuvem/gitql/releases/download/${pkgver}/gitql-linux64.1.zip"
- 'LICENSE::https://github.com/cloudson/gitql/raw/master/LICENSE')
-sha256sums=('ecdb8bc2dd28a4d216c2ec87d4d94cfeb406657c0c39e6cb6c511dca3ac51fa8'
+source=("${pkgname}-${pkgver}.zip::https://github.com/filhodanuvem/gitql/releases/download/${pkgver}/gitql-linux64.zip"
+ 'LICENSE::https://github.com/filhodanuvem/gitql/raw/main/LICENSE')
+sha256sums=('18a73ed06cbac727de7ab4f4ec18bd4f2046b297a06122aac46692e43e3a343a'
'ca995d876d4738b7f7309c46f443f42bc887db327ed183fe46733a59f06f80b5')
package() {
install -Dm755 gitql "${pkgdir}/usr/bin/gitql"
- install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm755 gitql "${pkgdir}/usr/bin/git-ql"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
-# vim:set ts=2 sw=2 et: