summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2018-06-04 00:56:18 +0200
committerNarrat2018-06-04 00:56:18 +0200
commitef3f33d527069f4efda3f3d44992533b587c4d02 (patch)
treeaa4207d97d7f08dabbd497a9889fc4cab3a37674
parentad4cdec79b7046a503cbb8f5523d562fb487a5ac (diff)
downloadaur-ef3f33d527069f4efda3f3d44992533b587c4d02.tar.gz
gitsome: update to 0.7.2
As python 3.6 is not supported, change dep to python 3.5. The broken state helped nobody. Change pypi download url to the pythonhosted one, where the checksum of the pypi url isn't included (see Arch Wiki) Small adjustments.
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a09a72abb2f..d59b5aad834 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
-# Generated by mksrcinfo v8
-# Tue Jun 28 13:12:40 UTC 2016
pkgbase = gitsome
- pkgdesc = A Supercharged Git/Shell Autocompleter with GitHub Integration.
- pkgver = 0.6.0
- pkgrel = 4
+ pkgdesc = Supercharged Git/Shell Autocompleter with GitHub Integration
+ pkgver = 0.7.2
+ pkgrel = 1
url = https://github.com/donnemartin/gitsome
arch = any
license = APACHE
makedepends = python-setuptools
- depends = python
+ depends = python35
depends = python-ply
depends = python-prompt_toolkit
depends = python-requests
@@ -22,20 +20,8 @@ pkgbase = gitsome
depends = python-numpydoc
conflicts = xonsh
conflicts = python-gitsome
- source = https://pypi.python.org/packages/30/9a/2ac38108d08869abbcb757f52f28b6730f6cf249b2f13c161783655f1a0f/gitsome-0.6.0.tar.gz
- md5sums = 66bf9620e442156cbb032851d33b75ed
+ source = https://files.pythonhosted.org/packages/source/g/gitsome/gitsome-0.7.2.tar.gz
+ md5sums = 7306daff07784650921e548d5886d5dd
pkgname = gitsome
- depends = python
- depends = python-ply
- depends = python-prompt_toolkit
- depends = python-requests
- depends = python-colorama
- depends = python-click
- depends = python-pygments
- depends = python-feedparser
- depends = python-pytz
- depends = python-docopt
- depends = python-uritemplate.py
- depends = python-numpydoc
diff --git a/PKGBUILD b/PKGBUILD
index 1cc7a3901ea..2ec3d883adb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+
pkgname=('gitsome')
_module='gitsome'
-pkgver='0.6.0'
-pkgrel=4
-pkgdesc="A Supercharged Git/Shell Autocompleter with GitHub Integration."
+pkgver='0.7.2'
+pkgrel=1
+pkgdesc="Supercharged Git/Shell Autocompleter with GitHub Integration"
url="https://github.com/donnemartin/gitsome"
-depends=('python' 'python-ply' 'python-prompt_toolkit' 'python-requests' 'python-colorama' 'python-click' 'python-pygments' 'python-feedparser' 'python-pytz' 'python-docopt' 'python-uritemplate.py' 'python-numpydoc')
+depends=('python35' 'python-ply' 'python-prompt_toolkit' 'python-requests' 'python-colorama' 'python-click' 'python-pygments' 'python-feedparser' 'python-pytz' 'python-docopt' 'python-uritemplate.py' 'python-numpydoc')
makedepends=('python-setuptools')
conflicts=('xonsh' 'python-gitsome')
license=('APACHE')
arch=('any')
-source=("https://pypi.python.org/packages/30/9a/2ac38108d08869abbcb757f52f28b6730f6cf249b2f13c161783655f1a0f/gitsome-${pkgver}.tar.gz")
-md5sums=('66bf9620e442156cbb032851d33b75ed')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/${_module}/${_module}-${pkgver}.tar.gz")
+md5sums=('7306daff07784650921e548d5886d5dd')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_module}-${pkgver}"
python setup.py build
}
package() {
- depends+=()
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_module}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}