summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorromkatv2020-05-24 10:53:39 +0200
committerromkatv2020-05-24 11:02:17 +0200
commitf56d906db7518e9ad96ec6633cc3e64bb467a454 (patch)
treea6dd14dc257a1b3f49706b4602980e5dedc3b34c
downloadaur-f56d906db7518e9ad96ec6633cc3e64bb467a454.tar.gz
add gitstatus-bin aur package
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
-rw-r--r--gitstatus.install10
4 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3b6e4fb1ed3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gitstatus-bin
+ pkgdesc = Git status for Bash and Zsh prompt
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://github.com/romkatv/gitstatus
+ install = gitstatus.install
+ arch = any
+ license = GPL3
+ makedepends = zsh
+ provides = gitstatus
+ source = gitstatus-bin-1.1.2.tar.gz::https://github.com/romkatv/gitstatus/archive/v1.1.2.tar.gz
+ sha512sums = d046090b6d2e8c56b58e907cbb9dad86609cfaefdea526813978c1c7846178c61cd91fa60b8ca036c4c5b6f55caaa17974c1a23f5055e2b4064ed072a3ba4f7d
+
+pkgname = gitstatus-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..50d29237ec80
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/gitstatus-*.pkg.tar.xz
+/gitstatus-*.tar.gz
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9835b456a16c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Roman Perepelitsa <roman.perepelitsa@gmail.com>
+
+pkgname=gitstatus-bin
+pkgver=1.1.2
+pkgrel=1
+pkgdesc='Git status for Bash and Zsh prompt'
+arch=('any')
+url="https://github.com/romkatv/gitstatus"
+license=('GPL3')
+provides=("gitstatus")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/romkatv/gitstatus/archive/v${pkgver}.tar.gz")
+sha512sums=('d046090b6d2e8c56b58e907cbb9dad86609cfaefdea526813978c1c7846178c61cd91fa60b8ca036c4c5b6f55caaa17974c1a23f5055e2b4064ed072a3ba4f7d')
+makedepends=('zsh')
+install='gitstatus.install'
+
+build() {
+ cd "$srcdir/gitstatus-${pkgver}"
+ zsh -fc '
+ emulate zsh -o no_aliases
+ unset -m "GITSTATUS_*"
+ GITSTATUS_CACHE_DIR="$PWD"/usrbin ./install -f'
+ for file in *.zsh install; do
+ zsh -fc "emulate zsh -o no_aliases && zcompile -R -- $file.zwc $file"
+ done
+}
+
+package() {
+ cd "$srcdir/gitstatus-${pkgver}"
+ find . -type f -exec install -D '{}' "$pkgdir/usr/share/gitstatus/{}" ';'
+}
diff --git a/gitstatus.install b/gitstatus.install
new file mode 100644
index 000000000000..8c04f871758f
--- /dev/null
+++ b/gitstatus.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo ">>> To activate gitstatus in Bash, add the following line to .bashrc:"
+ echo ">>> source /usr/share/gitstatus/gitstatus.prompt.sh"
+ echo ">>> To activate gitstatus in Zsh, add the following line to .zshrc:"
+ echo ">>> source /usr/share/gitstatus/gitstatus.prompt.zsh"
+}
+
+post_upgrade() {
+ post_install
+}