summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2016-09-20 22:40:41 -0400
committerKevin MacMartin2016-09-20 22:40:41 -0400
commit655af26787b4d359947875c86fd0fdc21eb3b3c2 (patch)
treeb16b77b870ab6bdec1df9930152e4f01829306d6
parentd95ee09ad8fc3a4a731072b9dc68a1769daab178 (diff)
downloadaur-655af26787b4d359947875c86fd0fdc21eb3b3c2.tar.gz
Update to 20160916.r37.c51c77f and remove the man page
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD45
-rw-r--r--gitsync.121
3 files changed, 21 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0a2a77396df..0d659fd007fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Wed Sep 21 02:38:56 UTC 2016
pkgbase = gitsync-git
pkgdesc = Git repository syncronisation daemon
- pkgver = 20131011.r35.296e001
- pkgrel = 2
+ pkgver = 20160916.r37.c51c77f
+ pkgrel = 1
url = https://github.com/raybejjani/gitsync
arch = i686
arch = x86_64
@@ -14,13 +16,7 @@ pkgbase = gitsync-git
makedepends = make
makedepends = python2
depends = glibc
- source = gitsync.1
source = git://github.com/raybejjani/gitsync.git
- source = git://github.com/ngmoco/timber.git
- source = hg+https://code.google.com/p/go.net/
- sha512sums = 9e292631ed38bc81c48b67294236da9e41e7a4e5839290973c76c53128f1c080635c92518452fa5410891037d312508002ced0d92b7dad6921ad63b7e3790ae2
- sha512sums = SKIP
- sha512sums = SKIP
sha512sums = SKIP
pkgname = gitsync-git
diff --git a/PKGBUILD b/PKGBUILD
index d7e7cb4f39a6..ab7eeffb39a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,35 @@
-# Maintainer: Prurigro
+# Maintainer: Kevin MacMartin <prurigro@gmail.com>
_pkgname=gitsync
-pkgname=${_pkgname}-git
-pkgver=20131011.r35.296e001
-pkgrel=2
-pkgdesc="Git repository syncronisation daemon"
-url="https://github.com/raybejjani/${_pkgname}"
+pkgname=$_pkgname-git
+pkgver=20160916.r37.c51c77f
+pkgrel=1
+pkgdesc='Git repository syncronisation daemon'
+url='https://github.com/raybejjani/gitsync'
license=('BSD')
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
depends=('glibc')
makedepends=('git' 'go' 'make' 'python2')
-source=("${_pkgname}.1"
- "git://github.com/raybejjani/${_pkgname}.git"
- "git://github.com/ngmoco/timber.git"
- "hg+https://code.google.com/p/go.net/")
-sha512sums=('9e292631ed38bc81c48b67294236da9e41e7a4e5839290973c76c53128f1c080635c92518452fa5410891037d312508002ced0d92b7dad6921ad63b7e3790ae2'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+source=("git://github.com/raybejjani/$_pkgname.git")
+sha512sums=('SKIP')
pkgver() {
- cd $_pkgname
- printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd $_pkgname
+ printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- sed -i 's|/usr/bin/env python|/usr/bin/env python2|g' ${_pkgname}/util/make_code_fs.py
-
- install -d ${_pkgname}/src/code.google.com/p/
- ln -s "${srcdir}/go.net" "${_pkgname}/src/code.google.com/p/go.net"
-
- install -d ${_pkgname}/src/github.com/ngmoco/
- ln -s "${srcdir}/timber" "${_pkgname}/src/github.com/ngmoco/timber"
+ sed -i 's|/usr/bin/env python|/usr/bin/env python2|g' "$_pkgname/build-util/make_code_fs.py"
}
build() {
- cd $_pkgname
- make
+ cd $_pkgname
+ export GOPATH="$srcdir/$_pkgname"
+ go get -tags='makebuild' github.com/raybejjani/gitsync/gitsyncd
+ make all
}
package() {
- install -Dm644 ${_pkgname}.1 "${pkgdir}/usr/share/man/man1/${_pkgname}.1"
- install -Dm644 ${_pkgname}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm755 ${_pkgname}/bin/${_pkgname}d "${pkgdir}/usr/bin/${_pkgname}d"
+ install -Dm755 $_pkgname/bin/${_pkgname}d "${pkgdir}/usr/bin/${_pkgname}d"
+ install -Dm644 $_pkgname/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/gitsync.1 b/gitsync.1
deleted file mode 100644
index 797e128b08a0..000000000000
--- a/gitsync.1
+++ /dev/null
@@ -1,21 +0,0 @@
-.\" Text automatically generated by txt2man
-.TH GITSYNC "BETA GIT" "INSTRUCTIONS"
-.RS
-.SH NAME
-gitsync
-.SH SYNOPSIS
-gitsync is a repository-syncronisation daemon, whose purpose is to keep coders on the same project aware of each others' work without requiring any pushes to remotes. Running on machines on the same local network, on any given peer it will auto-fetch any branches modified on the other peers.
-.PP
-For example, say Alice and Bob are working on repo 'foo' on their separate machines. With gitsyncd running on both machines, everytime Alice makes a local commit, Bob's machine will auto-fetch Alice's modified branch into a local one named `gitsync-Alice-<branch>`.
-.PP
-.SH RUNNING
-Run with `gitsyncd /path/to/repo`.
-.TP
-You can open up a local webserver to see a live-updating page of your coworkers' changes by supplying a port number:
-.TP
-.B
-\fbgitsyncd \fB-webport\fP=<port> /path/to/repo
-.TP
-Then go to `http://localhost:<port>` (it's very rudimentary for now).
-.TP
-See extended options by running `gitsyncd \fB-h\fP`.