summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTjaart van der Walt2015-06-14 15:46:31 -0500
committerTjaart van der Walt2015-06-14 16:39:25 -0500
commit3dac89ddd945021e7542c4aa2919e3f7143b055d (patch)
treef7571c9eca3010ee2375715406125e362d249458
downloadaur-3dac89ddd945021e7542c4aa2919e3f7143b055d.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD21
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4a2e7abce05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gitwatch-git
+ pkgdesc = A bash script to watch a file or folder and commit changes to a git repo
+ pkgver = r66.61c1aac
+ pkgrel = 1
+ url = https://github.com/nevik/gitwatch
+ arch = any
+ license = GPL3
+ depends = git
+ depends = inotify-tools
+ source = git+https://github.com/nevik/gitwatch.git
+ md5sums = SKIP
+
+pkgname = gitwatch-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5aa667f76829
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# Created by https://www.gitignore.io
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+gitwatch/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06adb2255d78
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Tjaart van der walt <aur@tjaart.co.za>
+
+pkgname=gitwatch-git
+pkgrel=1
+pkgdesc="A bash script to watch a file or folder and commit changes to a git repo"
+arch=('any')
+url="https://github.com/nevik/gitwatch"
+license=('GPL3')
+source=(git+https://github.com/nevik/gitwatch.git)
+depends=('git' 'inotify-tools')
+
+md5sums=('SKIP')
+
+# I tried to use the pkgver() function, but it returned -1
+pkgver=`cd gitwatch; printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"`
+
+package() {
+ pwd
+ mkdir -p $pkgdir/usr/bin
+ cp gitwatch/gitwatch.sh $pkgdir/usr/bin/gitwatch
+}