summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2014-03-15 18:01:30 +0200
committerCaleb Maclennan2014-03-15 18:01:30 +0200
commit70cfee2fbd041c24b3b0874c334ff2787ebffa74 (patch)
treea0c13d8a21d57ac42c9fe181cd9d4cda172cd938
downloadaur-70cfee2fbd041c24b3b0874c334ff2787ebffa74.tar.gz
add gitzone package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b4e38aa7904
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gitzone
+ pkgdesc = git-based zone management tool for static and dynamic domains
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/dyne/gitzone
+ arch = any
+ license = AGPL3
+ depends = perl
+ depends = bind
+ backup = etc/gitzone.conf
+ source = gitzone-1.0::https://github.com/dyne/gitzone/archive/v1.0.tar.gz
+ md5sums = 7dfedb6b4d350db97ed41f40519f4961
+
+pkgname = gitzone
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d34b6b67440e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+pkgname=gitzone
+pkgver=1.0
+pkgrel=1
+url=https://github.com/dyne/gitzone
+pkgdesc='git-based zone management tool for static and dynamic domains'
+arch=('any')
+license=('AGPL3')
+depends=('perl' 'bind')
+source=("${pkgname}-${pkgver}::https://github.com/dyne/$pkgname/archive/v${pkgver}.tar.gz")
+md5sums=('7dfedb6b4d350db97ed41f40519f4961')
+backup=('etc/gitzone.conf')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ find -type f -execdir sed -i 's#libexec/gitzone#usr/share/gitzone/libexec#g' {} \;
+ make PREFIX=$pkgdir/ install
+}
+