summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordumbasPL2023-07-18 00:49:33 +0200
committerdumbasPL2023-07-18 00:49:33 +0200
commit030ec53b4fcef6593be991fa541acfebbe90dd56 (patch)
treeb56eb7c4214e4e5dcd9bde0a1ad6b559bc2c0df7
parent422961becbe886f74eef87f5fb94503a92350d21 (diff)
downloadaur-030ec53b4fcef6593be991fa541acfebbe90dd56.tar.gz
remove pyinstaller, use system python packages
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD29
-rwxr-xr-xstart.sh3
4 files changed, 19 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3feb80c52614..a98c2cfe41ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = givemebadge-git
pkgdesc = Pretty simple Discord bot to get the active developer badge
- pkgver = 82d0c5c
+ pkgver = e17fb70
pkgrel = 1
url = https://github.com/AlexFlipnote/GiveMeBadge
arch = any
license = MIT
- makedepends = git
- makedepends = python-pip
depends = python
+ depends = python-colorama
+ depends = python-requests
+ depends = python-discord
provides = givemebadge
conflicts = givemebadge
+ source = start.sh
source = givemebadge::git+https://github.com/AlexFlipnote/GiveMeBadge
+ sha256sums = ef09169e18bb768d482a156ce918b33738e2b97b124c13aede1373464b8f6642
sha256sums = SKIP
pkgname = givemebadge-git
diff --git a/.gitignore b/.gitignore
index 4dccc7769c72..c941a0b48de7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,4 +4,5 @@
# But not these files...
!.gitignore
!PKGBUILD
-!.SRCINFO \ No newline at end of file
+!.SRCINFO
+!*.sh
diff --git a/PKGBUILD b/PKGBUILD
index d509219b9a0c..cf655ea92ff2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,26 @@
# Maintainer: nezu <nezu@nezu.cc>
pkgname=givemebadge-git
_pkgname=givemebadge
-pkgver=82d0c5c
+pkgver=e17fb70
pkgrel=1
pkgdesc="Pretty simple Discord bot to get the active developer badge"
arch=('any')
url="https://github.com/AlexFlipnote/GiveMeBadge"
license=('MIT')
-depends=('python')
-makedepends=('git' 'python-pip')
+depends=('python' 'python-colorama' 'python-requests' 'python-discord')
provides=('givemebadge')
conflicts=('givemebadge')
-source=("$_pkgname::git+$url")
-sha256sums=('SKIP')
+source=("start.sh" "$_pkgname::git+$url")
+sha256sums=('ef09169e18bb768d482a156ce918b33738e2b97b124c13aede1373464b8f6642'
+ 'SKIP')
pkgver() {
cd "$_pkgname"
git describe --tags --always | sed 's#v##;s#-#+#g;s#+#+r#'
}
-prepare() {
- cd "$_pkgname"
- export PATH=${HOME}/.local/bin:${PATH}
- pip install -r requirements.txt
- pip install pyinstaller
-}
-
-build() {
- cd "$_pkgname"
- export PATH=${HOME}/.local/bin:${PATH}
- pyinstaller index.py --onefile --icon=assets/logo.ico --name $_pkgname
-}
-
package() {
- cd "$_pkgname"
- install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/$_pkgname"
- install -Dm755 "dist/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 "$_pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$_pkgname"
+ install -Dm644 "$_pkgname/index.py" -t "$pkgdir/usr/share/$_pkgname"
+ install -Dm755 "start.sh" "$pkgdir/usr/bin/$_pkgname"
}
diff --git a/start.sh b/start.sh
new file mode 100755
index 000000000000..2469a1a1d4bd
--- /dev/null
+++ b/start.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec python3 /usr/share/givemebadge/index.py "$@"