summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2014-05-08 17:13:49 -0600
committerBrian Bidulock2015-06-10 05:44:00 -0600
commit318f459387c61e458989e4a74f8480d81067c9e8 (patch)
tree366f8c599903401ddb437635fcc912f239d5eef4
parent0c945cd69b4874708f6acbc7bc1a52418c3fe571 (diff)
downloadaur-318f459387c61e458989e4a74f8480d81067c9e8.tar.gz
version 0.7.9-2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d5c47e5650e..b921b07bf5de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
pkgbase = gjdoc
pkgdesc = GNU Classpath JavaDoc implementation
pkgver = 0.7.9
- pkgrel = 4
+ pkgrel = 2
url = http://savannah.gnu.org/projects/classpath/
- install = gjdoc.install
arch = i686
arch = x86_64
license = GPL
- depends = gcc-gcj>=5.1.0
- depends = java-environment
- noextract = antlr-2.7.7.jar
+ depends = gcc-gcj>=4.3.1
+ noextract = antlr-2.7.5.jar
options = !libtool
- options = !buildflags
source = http://ftp.gnu.org/gnu/classpath/gjdoc-0.7.9.tar.gz
- source = http://www.antlr2.org/download/antlr-2.7.7.jar
+ source = http://www.antlr2.org/download/antlr-2.7.5.jar
md5sums = 24cade2efe22d5adefcbabb21f094803
- md5sums = f8f1352c52a4c6a500b597596501fc64
+ md5sums = 6d57df718efd2a03981c309ce3330a1f
pkgname = gjdoc
diff --git a/PKGBUILD b/PKGBUILD
index 559e62379a97..932cfd52d31a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,32 @@
pkgname=gjdoc
pkgver=0.7.9
-pkgrel=4
+pkgrel=2
pkgdesc="GNU Classpath JavaDoc implementation"
arch=(i686 x86_64)
license=('GPL')
url="http://savannah.gnu.org/projects/classpath/"
-depends=('gcc-gcj>=5.1.0' 'java-environment')
-options=('!libtool' '!buildflags')
-noextract=('antlr-2.7.7.jar')
-install=$pkgname.install
+depends=('gcc-gcj>=4.3.1')
+options=('!libtool')
+noextract=('antlr-2.7.5.jar')
source=(http://ftp.gnu.org/gnu/classpath/${pkgname}-${pkgver}.tar.gz
- http://www.antlr2.org/download/antlr-2.7.7.jar)
+ http://www.antlr2.org/download/antlr-2.7.5.jar)
md5sums=('24cade2efe22d5adefcbabb21f094803'
- 'f8f1352c52a4c6a500b597596501fc64')
+ '6d57df718efd2a03981c309ce3330a1f')
build() {
- cd $pkgname-$pkgver
- ./configure --prefix=/usr --with-antlr-jar=${srcdir}/antlr-2.7.7.jar
+ export -n CFLAGS
+ export -n CXXFLAGS
+ export -n LDFLAGS
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --with-antlr-jar=${srcdir}/antlr-2.7.5.jar || return 1
make || find . -type f -name '*.o' | while read f; do objcopy -L '_ZGr8_$_dummy' $f; done
make || find . -type f -name '*.o' | while read f; do objcopy -L '_ZGr8_$_dummy' $f; done
make || find . -type f -name '*.o' | while read f; do objcopy -L '_ZGr8_$_dummy' $f; done
make || find . -type f -name '*.o' | while read f; do objcopy -L '_ZGr8_$_dummy' $f; done
- make GCJFLAGS='-g -O2 -fsource=1.3'
+ make || return 1
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR=${pkgdir} install
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install || return 1
}