summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2015-09-24 10:18:50 +1000
committerRhinoceros2015-09-24 10:18:50 +1000
commit7444801e02568fa0ca2660d2aac8cd106739c373 (patch)
tree96aa0f2ce325950308278626e97eac8b1ffb6090
downloadaur-7444801e02568fa0ca2660d2aac8cd106739c373.tar.gz
Initial commit of 0.3.r10.g27779a9
* Based on gkeyring 0.3-2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25cdbd8b8c16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gkeyring-git
+ pkgdesc = A small Python tool for shell access to GNOME keyring. It provides simple querying for and creating of keyring items.
+ pkgver = 0.3.r10.g27779a9
+ pkgrel = 1
+ url = https://github.com/kparal/gkeyring
+ arch = any
+ license = AGPL3
+ depends = python2
+ depends = python2-gnomekeyring
+ depends = python2-distribute
+ conflicts = gkeyring
+ options = !emptydirs
+ source = gkeyring::git+https://github.com/kparal/gkeyring
+ md5sums = SKIP
+
+pkgname = gkeyring-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d2310584562
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+# Contributor: Jakob Nixdorf <flocke [swirly thing] shadowice [dot] org>
+# Contributor: Vinícius dos Santos Oliveira <vini [dot] ipsmaker [at] gmail [dot] com>
+
+pkgname=gkeyring-git
+pkgver=0.3.r10.g27779a9
+pkgrel=1
+pkgdesc='A small Python tool for shell access to GNOME keyring. It provides simple querying for and creating of keyring items.'
+arch=('any')
+url='https://github.com/kparal/gkeyring'
+license=('AGPL3')
+depends=('python2' 'python2-gnomekeyring' 'python2-distribute')
+conflicts=('gkeyring')
+options=(!emptydirs)
+source=(${pkgname%-git}::git+https://github.com/kparal/gkeyring)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${pkgname%-git}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+}