summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSophie Tauchert2020-05-22 11:28:11 +0200
committerSophie Tauchert2020-05-22 11:28:11 +0200
commit67b14401e6c5e84463ae1c36758b926027a179c0 (patch)
tree01246459a74b1e5bf163e25f8f0d1d3ef8b37f38
downloadaur-67b14401e6c5e84463ae1c36758b926027a179c0.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--60-gkraken.rules1
-rw-r--r--PKGBUILD35
-rw-r--r--gkraken.install5
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fdf61174fc37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = gkraken
+ pkgdesc = GUI that allows to control cooling of NZXT Kraken X (X42, X52, X62 or X72) pumps from Linux
+ pkgver = 0.14.0
+ pkgrel = 1
+ url = https://gitlab.com/leinardi/gkraken
+ install = gkraken.install
+ arch = any
+ license = GPL3
+ makedepends = meson
+ makedepends = appstream-glib
+ depends = gobject-introspection
+ depends = libappindicator-gtk3
+ depends = liquidctl
+ depends = python
+ depends = python-gobject
+ depends = python-hidapi
+ depends = python-injector
+ depends = python-matplotlib
+ depends = python-peewee
+ depends = python-psutil
+ depends = python-pyxdg
+ depends = python-requests
+ depends = python-rx
+ source = https://gitlab.com/leinardi/gkraken/-/archive/0.14.0/gkraken-0.14.0.tar.gz
+ source = 60-gkraken.rules
+ sha256sums = 3a9f926cf54690dc61641e63e8352fbe3ff647740bf27ea712179275c13f90bc
+ sha256sums = 26ce441dbe4a6e4e0ae879570612aa60e268eb0a5ef26589c40ad117b51bfb8c
+
+pkgname = gkraken
+
diff --git a/60-gkraken.rules b/60-gkraken.rules
new file mode 100644
index 000000000000..93cc1c649dc9
--- /dev/null
+++ b/60-gkraken.rules
@@ -0,0 +1 @@
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="1e71", ATTRS{idProduct}=="170e", MODE="0666"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46824c139c16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Sophie Tauchert <sophie@999eagle.moe>
+
+pkgname=gkraken
+pkgver=0.14.0
+pkgrel=1
+pkgdesc="GUI that allows to control cooling of NZXT Kraken X (X42, X52, X62 or X72) pumps from Linux"
+arch=('any')
+url="https://gitlab.com/leinardi/gkraken"
+license=('GPL3')
+depends=('gobject-introspection' 'libappindicator-gtk3' 'liquidctl' 'python' 'python-gobject' 'python-hidapi' 'python-injector' 'python-matplotlib' 'python-peewee' 'python-psutil' 'python-pyxdg' 'python-requests' 'python-rx')
+makedepends=('meson' 'appstream-glib')
+provides=()
+conflicts=()
+install="$pkgname.install"
+source=("https://gitlab.com/leinardi/gkraken/-/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+ '60-gkraken.rules')
+sha256sums=('3a9f926cf54690dc61641e63e8352fbe3ff647740bf27ea712179275c13f90bc'
+ '26ce441dbe4a6e4e0ae879570612aa60e268eb0a5ef26589c40ad117b51bfb8c')
+
+build() {
+ if [[ -d "$srcdir/build" ]]; then
+ rm -rf "$srcdir/build"
+ fi
+ meson --prefix /usr --buildtype=plain "$pkgname-$pkgver" build
+ ninja -C build
+}
+
+check() {
+ ninja -C build test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+ install -Dm644 "$srcdir/60-gkraken.rules" "$pkgdir/usr/lib/udev/rules.d/60-gkraken.rules"
+}
diff --git a/gkraken.install b/gkraken.install
new file mode 100644
index 000000000000..616e0af1b0b1
--- /dev/null
+++ b/gkraken.install
@@ -0,0 +1,5 @@
+post_install() {
+ printf "$(tput setaf 4)To use gkraken as non-root user you need to reload the udev rules$(tput sgr0)\n"
+ printf "$(tput setaf 2)sudo udevadm control --reload-rules$(tput sgr0)\n"
+ printf "$(tput setaf 2)sudo udevadm trigger --subsystem-match=usb --attr-match=idVendor=1e71 --action=add$(tput sgr0)\n"
+}