summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSophie Tauchert2021-10-21 16:27:54 +0200
committerSophie Tauchert2021-10-21 16:27:54 +0200
commitb81d47a7a4aa2ac6a2b7a83e59b88221746f17b9 (patch)
treef413db3374f8aa0ae24f22979d05919ed5c52091
parent08dd4611049f1d16326eb5ac593b3f8361bb6ee9 (diff)
downloadaur-b81d47a7a4aa2ac6a2b7a83e59b88221746f17b9.tar.gz
Add missing udev rules and cairo dependency
-rw-r--r--.SRCINFO5
-rw-r--r--60-gkraken.rules3
-rw-r--r--PKGBUILD6
-rw-r--r--gkraken.install1
4 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc9f61a2fbec..32fd8f624943 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gkraken
pkgdesc = GUI that allows to control cooling of NZXT Kraken X (X42, X52, X62 or X72) pumps from Linux
pkgver = 1.1.7
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/leinardi/gkraken
install = gkraken.install
arch = any
@@ -12,6 +12,7 @@ pkgbase = gkraken
depends = libappindicator-gtk3
depends = liquidctl
depends = python
+ depends = python-cairo
depends = python-gobject
depends = python-hidapi
depends = python-injector
@@ -24,6 +25,6 @@ pkgbase = gkraken
source = https://gitlab.com/leinardi/gkraken/-/archive/1.1.7/gkraken-1.1.7.tar.gz
source = 60-gkraken.rules
sha256sums = a55a69b2735995aa3ce3cc826cf22206dadaac77d666815ab19e5cd5442df725
- sha256sums = 26ce441dbe4a6e4e0ae879570612aa60e268eb0a5ef26589c40ad117b51bfb8c
+ sha256sums = fccd2b7d1bfbee559dbd9bf62c9ab09784013bf86d9dd58558268fcf0cb195af
pkgname = gkraken
diff --git a/60-gkraken.rules b/60-gkraken.rules
index 93cc1c649dc9..26b5454a6b35 100644
--- a/60-gkraken.rules
+++ b/60-gkraken.rules
@@ -1 +1,4 @@
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1e71", ATTRS{idProduct}=="170e", MODE="0666"
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="1e71", ATTRS{idProduct}=="2007", MODE="0666"
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="1e71", ATTRS{idProduct}=="3008", MODE="0666"
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="2433", ATTRS{idProduct}=="b200", MODE="0666"
diff --git a/PKGBUILD b/PKGBUILD
index 7b3c3a8e8d20..26793410ea24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=gkraken
pkgver=1.1.7
-pkgrel=1
+pkgrel=2
pkgdesc="GUI that allows to control cooling of NZXT Kraken X (X42, X52, X62 or X72) pumps from Linux"
arch=('any')
url="https://gitlab.com/leinardi/gkraken"
license=('GPL3')
-depends=('gobject-introspection' 'libappindicator-gtk3' 'liquidctl' 'python' 'python-gobject' 'python-hidapi' 'python-injector' 'python-matplotlib' 'python-peewee' 'python-psutil' 'python-pyxdg' 'python-requests' 'python-rx')
+depends=('gobject-introspection' 'libappindicator-gtk3' 'liquidctl' 'python' 'python-cairo' 'python-gobject' 'python-hidapi' 'python-injector' 'python-matplotlib' 'python-peewee' 'python-psutil' 'python-pyxdg' 'python-requests' 'python-rx')
makedepends=('meson' 'appstream-glib')
provides=()
conflicts=()
@@ -15,7 +15,7 @@ install="$pkgname.install"
source=("https://gitlab.com/leinardi/gkraken/-/archive/$pkgver/$pkgname-$pkgver.tar.gz"
'60-gkraken.rules')
sha256sums=('a55a69b2735995aa3ce3cc826cf22206dadaac77d666815ab19e5cd5442df725'
- '26ce441dbe4a6e4e0ae879570612aa60e268eb0a5ef26589c40ad117b51bfb8c')
+ 'fccd2b7d1bfbee559dbd9bf62c9ab09784013bf86d9dd58558268fcf0cb195af')
build() {
if [[ -d "$srcdir/build" ]]; then
diff --git a/gkraken.install b/gkraken.install
index 616e0af1b0b1..c9083586cf03 100644
--- a/gkraken.install
+++ b/gkraken.install
@@ -2,4 +2,5 @@ post_install() {
printf "$(tput setaf 4)To use gkraken as non-root user you need to reload the udev rules$(tput sgr0)\n"
printf "$(tput setaf 2)sudo udevadm control --reload-rules$(tput sgr0)\n"
printf "$(tput setaf 2)sudo udevadm trigger --subsystem-match=usb --attr-match=idVendor=1e71 --action=add$(tput sgr0)\n"
+ printf "$(tput setaf 2)sudo udevadm trigger --subsystem-match=usb --attr-match=idVendor=2433 --action=add$(tput sgr0)\n"
}