summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTroy Engel2015-06-13 18:03:02 -0500
committerTroy Engel2015-06-13 18:03:02 -0500
commitdf71a14f8be115ad32606538734b0af0a04e52a5 (patch)
tree93f10a5c6364567ff12fad39ab8b1f9c31a78be0
downloadaur-df71a14f8be115ad32606538734b0af0a04e52a5.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD49
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85ff05addcf7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gkrellm-themes
+ pkgdesc = Themes from muhri.net for GKrellM
+ pkgver = 20030109
+ pkgrel = 1
+ url = http://www.muhri.net/gkrellm/
+ arch = any
+ license = GPL
+ depends = gkrellm
+ options = !emptydirs
+ options = !strip
+ options = libtool
+ options = staticlibs
+ options = !zipman
+ source = http://www.muhri.net/gkrellm/GKrellM-Skins.tar.gz
+ sha256sums = a0d2d00410cc2290df6c89cba9a204a0592e8c18ba9e13e967dbf021937d30d1
+
+pkgname = gkrellm-themes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55e8202f5e8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Troy Engel <troyengel+arch@gmail.com>
+
+pkgname=gkrellm-themes
+pkgver=20030109
+pkgrel=1
+arch=('any')
+url="http://www.muhri.net/gkrellm/"
+license=('GPL')
+pkgdesc="Themes from muhri.net for GKrellM"
+depends=('gkrellm')
+source=('http://www.muhri.net/gkrellm/GKrellM-Skins.tar.gz')
+sha256sums=('a0d2d00410cc2290df6c89cba9a204a0592e8c18ba9e13e967dbf021937d30d1')
+
+# No binaries - speed up the package build (except emptydirs - needed)
+options=('!emptydirs' '!strip' 'libtool' 'staticlibs' '!zipman')
+
+prepare() {
+ cd "${srcdir}/GKrellM-skins"
+ # Deduped tarballs
+ rm -f aliens.tgz cyrus.gkrellm.tar.gz glass.gkrellm.tar.gz IReX.tar.gz
+ # Corrupted tarballs
+ rm -f Crux_chaos.tar.gz egan-gkrellm.tar.gz
+}
+
+package(){
+ # Unpack the tarballs, omitting trash
+ cd "${srcdir}/GKrellM-skins"
+ install -dm 755 "${pkgdir}/usr/share/gkrellm2/themes"
+ for file in *gz ; do
+ tar zxC "${pkgdir}/usr/share/gkrellm2/themes" -f $file \
+ --exclude CVS \
+ --exclude "*~" \
+ --exclude "*.swp" \
+ --exclude .xvpics \
+ --no-same-owner \
+ --no-same-permissions
+ done
+
+ # Several directories in the tarballs are 777 and files 755, some SGID.
+ # The tar extract options should have fixed this, let's be 100% sure.
+ cd "${pkgdir}/usr/share/gkrellm2/themes"
+ find . -type d -print0 | xargs -0 chmod 0755
+ find . -type f -print0 | xargs -0 chmod 0644
+
+ # Random fixes
+ cd "${pkgdir}/usr/share/gkrellm2/themes/twilite"
+ rm -f './.png' && ln -s 'green/frame_right.png' './.png'
+}
+