summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-12-29 22:08:09 -0700
committerBrian Bidulock2015-12-29 22:08:09 -0700
commite544b6622318fcf1f1bfa67de9d6682653b0b9a3 (patch)
tree34bdcb458e7122cc4a449e0a287fa78738514ee2
parent456daeee181457a6f15563f1930cf87c4934b13a (diff)
downloadaur-e544b6622318fcf1f1bfa67de9d6682653b0b9a3.tar.gz
version 2.0.8-3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD30
2 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ba5554e4922..911eb298e71b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
+# Generated by mksrcinfo v8
+# Wed Dec 30 05:07:29 UTC 2015
pkgbase = gkrellweather
pkgdesc = A weather monitor plugin for gkrellm2
pkgver = 2.0.8
- pkgrel = 2
- url = http://makovick.googlepages.com/gkrellmplugins
+ pkgrel = 3
+ url = https://sites.google.com/site/makovick/gkrellm-plugins
arch = i686
arch = x86_64
license = GPL
@@ -10,7 +12,7 @@ pkgbase = gkrellweather
depends = perl
depends = wget
depends = gtk2
- source = http://wwwcip.informatik.uni-erlangen.de/~sijojord/gkrellweather-2.0.8.tgz
+ source = gkrellweather-2.0.8.tgz::https://sites.google.com/site/makovick/projects/gkrellweather-2.0.8.tgz?attredirects=0
md5sums = b21ed55cc9998eb7307ec53e99f9beea
pkgname = gkrellweather
diff --git a/PKGBUILD b/PKGBUILD
index fa1646c4c613..19f670c60aa0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,30 @@
-# Maintainer: Jonathan Kotta <jpkotta at gmail dot com>
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Jonathan Kotta <jpkotta at gmail dot com>
# Contributor: Manolis Tzanidakis
pkgname=gkrellweather
pkgver=2.0.8
-pkgrel=2
+pkgrel=3
pkgdesc="A weather monitor plugin for gkrellm2"
arch=('i686' 'x86_64')
depends=('gkrellm' 'perl' 'wget' 'gtk2')
license=('GPL')
-url="http://makovick.googlepages.com/gkrellmplugins"
-source=("http://wwwcip.informatik.uni-erlangen.de/~sijojord/$pkgname-$pkgver.tgz")
+url="https://sites.google.com/site/makovick/gkrellm-plugins"
+source=("${pkgname}-${pkgver}.tgz::https://sites.google.com/site/makovick/projects/${pkgname}-${pkgver}.tgz?attredirects=0")
md5sums=('b21ed55cc9998eb7307ec53e99f9beea')
build() {
- cd $srcdir/$pkgname-$pkgver
-
- /bin/sed -i -e 's|/usr/local|/usr|' Makefile
- /bin/sed -i -e 's|PREFIX|"/usr/share/gkrellm"|' gkrellweather.c
- /bin/sed -i -e 's|/bin/GrabWeather|/GrabWeather|' gkrellweather.c
-
- /usr/bin/make || return 1
+ cd $pkgname-$pkgver
+ sed -i -e 's|/usr/local|/usr|' Makefile
+ sed -i -e 's|PREFIX|"/usr/share/gkrellm"|' gkrellweather.c
+ sed -i -e 's|/bin/GrabWeather|/GrabWeather|' gkrellweather.c
+ make
}
package() {
- cd $srcdir/$pkgname-$pkgver
- install -D -m755 gkrellweather.so \
- $pkgdir/usr/lib/gkrellm2/plugins/gkrellweather.so
- install -D -m755 GrabWeather \
- $pkgdir/usr/share/gkrellm/GrabWeather
+ cd $pkgname-$pkgver
+ install -D -m755 gkrellweather.so "$pkgdir/usr/lib/gkrellm2/plugins/gkrellweather.so"
+ install -D -m755 GrabWeather "$pkgdir/usr/share/gkrellm/GrabWeather"
}
+
# vim: ts=2 sw=2 et ft=sh