summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLara Maia2015-06-12 00:41:49 -0300
committerLara Maia2015-06-12 00:41:49 -0300
commit872fce4b235a586225e452f8acd92f6b9651df2b (patch)
tree9005afeeb96066a54cf702853e393c9edcfe357a
downloadaur-gl-z.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3d58c652f22
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gl-z
+ pkgdesc = cross-platform GL info tool
+ pkgver = 0.1.0
+ pkgrel = 2
+ url = http://www.geeks3d.com/20141121/gl-z-opengl-information-utility-extensions-viewer-for-windows-linux-and-os-x/
+ arch = any
+ license = custom
+ makedepends = unzip
+ depends = glslhacker
+ source = http://www.ozone3d.net/dl/201411/GL-Z-010-linux64.zip
+ md5sums = 1993c3ca62f723609c1b43e69d4513eb
+
+pkgname = gl-z
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3aca205ba6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Lara Maia <lara@craft.net.br>
+DLAGENTS=('http::/usr/bin/curl -e "http://www.geeks3d.com/20131028/gputest-0-6-0-opengl-benchmark-for-windows-mac-os-x-and-linux-downloads/" -fLC - --retry 3 --retry-delay 3 -o %o %u')
+
+pkgname=gl-z
+pkgdesc="cross-platform GL info tool"
+url='http://www.geeks3d.com/20141121/gl-z-opengl-information-utility-extensions-viewer-for-windows-linux-and-os-x/'
+license=("custom");
+arch=('any');
+pkgver=0.1.0
+pkgrel=2
+
+source=('http://www.ozone3d.net/dl/201411/GL-Z-010-linux64.zip')
+md5sums=('1993c3ca62f723609c1b43e69d4513eb')
+
+depends=('glslhacker')
+makedepends=('unzip')
+
+package() {
+ cd "GL-Z-linux64"
+
+ install -Dm644 README.txt "$pkgdir/usr/share/licenses/$pkgname/README.txt"
+
+ install -dm755 "$pkgdir/usr/share/$pkgname/"
+ install -Dm644 glz_src/glz.xml "$pkgdir/usr/share/$pkgname/"
+ cp -rf glz_src/data "$pkgdir/usr/share/$pkgname/"
+
+ install -dm755 "$pkgdir/usr/bin/"
+ echo -e "#!/bin/bash\nglslhacker /demofile=\\\"/usr/share/$pkgname/glz.xml\\\"" > "$pkgdir/usr/bin/gl-z"
+ chmod 755 "$pkgdir/usr/bin/gl-z"
+}