summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhoton892016-04-12 21:56:41 +0200
committerPhoton892016-04-12 21:56:41 +0200
commit3a17df15be102da7388b9cc27b6a80e959bd2c98 (patch)
tree51a8171f034a236be0073f65edc01b7428eccf8a
downloadaur-3a17df15be102da7388b9cc27b6a80e959bd2c98.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD35
-rw-r--r--glabels.install15
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..118961156e57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = glabels-light
+ pkgdesc = Creating labels and business cards the very easy way - minimal dependencies
+ pkgver = 3.2.1
+ pkgrel = 1
+ url = http://glabels.org/
+ install = glabels.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = intltool
+ makedepends = itstool
+ depends = librsvg
+ depends = dconf
+ depends = desktop-file-utils
+ depends = xdg-utils
+ optdepends = evolution-data-server: import Evolution contacts
+ optdepends = qrencode: use QR codes
+ optdepends = iec16022: use barcodes
+ provides = glabels
+ conflicts = glabels
+ source = http://ftp.gnome.org/pub/GNOME/sources/glabels/3.2/glabels-3.2.1.tar.xz
+ sha256sums = db615f653b6e78ef1209814b5e6d8d3af4f8d3444a259ddbcc0dfb279c7df855
+
+pkgname = glabels-light
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01667712a056
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Michael Kogan photon89 at googlemail dot com>
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: yugrotavele <yugrotavele at archlinux dot us>
+# Contributor: Damir Perisa <damir@archlinux.org>
+
+pkgname=glabels-light
+_pkgname=glabels
+pkgver=3.2.1
+pkgrel=1
+pkgdesc="Creating labels and business cards the very easy way - minimal dependencies"
+arch=('i686' 'x86_64')
+url="http://glabels.org/"
+license=('GPL' 'LGPL')
+depends=('librsvg' 'dconf' 'desktop-file-utils' 'xdg-utils')
+optdepends=('evolution-data-server: import Evolution contacts'
+ 'qrencode: use QR codes'
+ 'iec16022: use barcodes')
+conflicts=('glabels')
+provides=('glabels')
+makedepends=('intltool' 'itstool')
+install=$_pkgname.install
+source=(http://ftp.gnome.org/pub/GNOME/sources/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.xz)
+sha256sums=('db615f653b6e78ef1209814b5e6d8d3af4f8d3444a259ddbcc0dfb279c7df855')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-static --disable-schemas-compile
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/glabels.install b/glabels.install
new file mode 100644
index 000000000000..42bb5884d5d6
--- /dev/null
+++ b/glabels.install
@@ -0,0 +1,15 @@
+post_install() {
+ xdg-icon-resource forceupdate
+ update-desktop-database -q
+ update-mime-database usr/share/mime &> /dev/null
+ glib-compile-schemas usr/share/glib-2.0/schemas
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+
+post_remove() {
+ post_install $1
+}