summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Blättermann2018-12-05 22:05:07 +0100
committerMario Blättermann2018-12-05 22:05:07 +0100
commit5e7c0d3aff0683689fe3cc655c3bd77f87f0c524 (patch)
treec366ed886fce12a281ce0c71d51d6b3ee7c0cd9e
downloadaur-5e7c0d3aff0683689fe3cc655c3bd77f87f0c524.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD47
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09b122c3aade
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = glabels-qt-git
+ pkgdesc = Development version of the next major version of gLabels (4.0).
+ pkgver = r463.e0b9eeb
+ pkgrel = 1
+ url = https://github.com/jimevins/glabels-qt
+ arch = x86_64
+ license = GPL3
+ makedepends = qt5-tools
+ makedepends = git
+ makedepends = cmake
+ makedepends = zint
+ depends = qt5-base
+ depends = qt5-translations
+ provides = glabels-qt
+ conflicts = glabels-qt
+ source = git+https://github.com/jimevins/glabels-qt.git
+ md5sums = SKIP
+
+pkgname = glabels-qt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4dd58b34430
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Mario Blättermann <mario.blaettermann@gmail.com>
+pkgname=glabels-qt-git
+pkgver=r463.e0b9eeb
+pkgrel=1
+pkgdesc="Development version of the next major version of gLabels (4.0)."
+arch=('x86_64')
+url="https://github.com/jimevins/glabels-qt"
+license=('GPL3')
+groups=()
+depends=('qt5-base' 'qt5-translations')
+makedepends=('qt5-tools' 'git' 'cmake' 'zint')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/jimevins/glabels-qt.git')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ cd build
+ make DESTDIR="$pkgdir/" install
+}