summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2016-05-22 14:19:56 +0200
committerMuflone2016-05-22 14:20:37 +0200
commit81be5190acbf40ea22bb36e76644733f73854bf4 (patch)
tree14d103650a8ebf316f2a8d97efadcd15ff36363f
parent9644514db0f99325293e7282a1a4b56193036351 (diff)
downloadaur-81be5190acbf40ea22bb36e76644733f73854bf4.tar.gz
Updated package glade-gtk2 3.8.5-4
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
-rw-r--r--glade-gtk2.install12
-rw-r--r--no-check-format-nonliteral.patch27
4 files changed, 42 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93a75a0c247a..570155c5d895 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
+# Generated by mksrcinfo v8
+# Sun May 22 12:19:22 UTC 2016
pkgbase = glade-gtk2
pkgdesc = User interface builder for GTK+ and GNOME (latest version for GTK2)
pkgver = 3.8.5
- pkgrel = 3
+ pkgrel = 4
url = http://glade.gnome.org/
- install = glade-gtk2.install
arch = i686
arch = x86_64
license = GPL
@@ -19,7 +20,9 @@ pkgbase = glade-gtk2
optdepends = python2: Python widgets support
options = !libtool
source = http://ftp.gnome.org/pub/GNOME/sources/glade3/3.8/glade3-3.8.5.tar.xz
+ source = no-check-format-nonliteral.patch
sha256sums = 58a5f6e4df4028230ddecc74c564808b7ec4471b1925058e29304f778b6b2735
+ sha256sums = e2b383720f5ab53fc581f71f8d6aac5bd0080245400eaef9b29030d7c88fb66b
pkgname = glade-gtk2
diff --git a/PKGBUILD b/PKGBUILD
index c3256b25367a..64fdadde5242 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=glade-gtk2
_pkgname=glade3
pkgver=3.8.5
-pkgrel=3
+pkgrel=4
pkgdesc='User interface builder for GTK+ and GNOME (latest version for GTK2)'
arch=('i686' 'x86_64')
license=('GPL' 'LGPL')
@@ -16,11 +16,17 @@ makedepends=('intltool' 'python2' 'gobject-introspection' 'python2-gobject2' 'gt
optdepends=('devhelp: Integrated docs'
'python2: Python widgets support')
url='http://glade.gnome.org/'
-install="${pkgname}.install"
-source=("http://ftp.gnome.org/pub/GNOME/sources/${_pkgname}/${pkgver:0:3}/${_pkgname}-${pkgver}.tar.xz")
-sha256sums=('58a5f6e4df4028230ddecc74c564808b7ec4471b1925058e29304f778b6b2735')
+source=("http://ftp.gnome.org/pub/GNOME/sources/${_pkgname}/${pkgver:0:3}/${_pkgname}-${pkgver}.tar.xz"
+ "no-check-format-nonliteral.patch")
+sha256sums=('58a5f6e4df4028230ddecc74c564808b7ec4471b1925058e29304f778b6b2735'
+ 'e2b383720f5ab53fc581f71f8d6aac5bd0080245400eaef9b29030d7c88fb66b')
options=('!libtool')
+prepare() {
+ cd "${_pkgname}-${pkgver}"
+ patch -p2 -i "${srcdir}/no-check-format-nonliteral.patch"
+}
+
build() {
cd "${_pkgname}-${pkgver}"
PYTHON=/usr/bin/python2 ./configure --prefix=/usr --sysconfdir=/etc \
diff --git a/glade-gtk2.install b/glade-gtk2.install
deleted file mode 100644
index bce670aff4af..000000000000
--- a/glade-gtk2.install
+++ /dev/null
@@ -1,12 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}
diff --git a/no-check-format-nonliteral.patch b/no-check-format-nonliteral.patch
new file mode 100644
index 000000000000..134b54b16204
--- /dev/null
+++ b/no-check-format-nonliteral.patch
@@ -0,0 +1,27 @@
+--- src/glade3-3.8.5/gladeui/glade-editor-property.c 2014-04-23 23:08:02.000000000 +0200
++++ glade-editor-property.c 2016-05-22 14:05:18.871026000 +0200
+@@ -72,7 +72,6 @@
+ #define FLAGS_COLUMN_SETTING 0
+ #define FLAGS_COLUMN_SYMBOL 1
+
+-
+ /*******************************************************************************
+ GladeEditorPropertyClass
+ *******************************************************************************/
+@@ -2716,6 +2715,8 @@
+ format = GLADE_IS_PARAM_SPEC_OBJECTS (eprop->klass->pspec) ?
+ _("Choose %s type objects in this project") : _("Choose a %s in this project");
+
++ #pragma GCC diagnostic push
++ #pragma GCC diagnostic ignored "-Wformat-nonliteral"
+ if (GLADE_IS_PARAM_SPEC_OBJECTS (eprop->klass->pspec))
+ return g_strdup_printf (format, g_type_name
+ (glade_param_spec_objects_get_type
+@@ -2730,6 +2731,7 @@
+ */
+ return g_strdup_printf (format, g_type_name
+ (eprop->klass->pspec->value_type));
++ #pragma GCC diagnostic pop
+ }
+
+