summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-08-09 00:15:02 +0200
committerMuflone2015-08-09 00:25:31 +0200
commit9644514db0f99325293e7282a1a4b56193036351 (patch)
treeca2a93efbf7ce760d218b18c38229d7c735c8434
downloadaur-9644514db0f99325293e7282a1a4b56193036351.tar.gz
Updateed package glade-gtk2 3.8.5-3
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD39
-rw-r--r--glade-gtk2.install12
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93a75a0c247a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = glade-gtk2
+ pkgdesc = User interface builder for GTK+ and GNOME (latest version for GTK2)
+ pkgver = 3.8.5
+ pkgrel = 3
+ url = http://glade.gnome.org/
+ install = glade-gtk2.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = intltool
+ makedepends = python2
+ makedepends = gobject-introspection
+ makedepends = python2-gobject2
+ makedepends = gtk-doc
+ depends = gtk2
+ depends = desktop-file-utils
+ optdepends = devhelp: Integrated docs
+ optdepends = python2: Python widgets support
+ options = !libtool
+ source = http://ftp.gnome.org/pub/GNOME/sources/glade3/3.8/glade3-3.8.5.tar.xz
+ sha256sums = 58a5f6e4df4028230ddecc74c564808b7ec4471b1925058e29304f778b6b2735
+
+pkgname = glade-gtk2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3256b25367a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+# Contributor: Nuno Araujo <nuno.araujo@russo79.com>
+# Contributor: TingPing <tingping@tingping.se>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+# Contributor: Fabien COUTANT
+
+pkgname=glade-gtk2
+_pkgname=glade3
+pkgver=3.8.5
+pkgrel=3
+pkgdesc='User interface builder for GTK+ and GNOME (latest version for GTK2)'
+arch=('i686' 'x86_64')
+license=('GPL' 'LGPL')
+depends=('gtk2' 'desktop-file-utils')
+makedepends=('intltool' 'python2' 'gobject-introspection' 'python2-gobject2' 'gtk-doc')
+optdepends=('devhelp: Integrated docs'
+ 'python2: Python widgets support')
+url='http://glade.gnome.org/'
+install="${pkgname}.install"
+source=("http://ftp.gnome.org/pub/GNOME/sources/${_pkgname}/${pkgver:0:3}/${_pkgname}-${pkgver}.tar.xz")
+sha256sums=('58a5f6e4df4028230ddecc74c564808b7ec4471b1925058e29304f778b6b2735')
+options=('!libtool')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --disable-static
+ make
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -f "${pkgdir}/usr/share/glade3/catalogs"/*.in
+ # We append (GTK2) to the Name entries in the .desktop file
+ # to recognize the variant we wish to work with if we have
+ # both the GTK3 and GTK2 variants installed
+ sed -i 's/Name.*/& (GTK2)/g' "${pkgdir}/usr/share/applications/glade-3.desktop"
+}
diff --git a/glade-gtk2.install b/glade-gtk2.install
new file mode 100644
index 000000000000..bce670aff4af
--- /dev/null
+++ b/glade-gtk2.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}