summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFraV19822024-03-24 20:25:14 +0100
committerFraV19822024-03-24 20:25:14 +0100
commit334487845d8fa1acc0becb08a27096dbc75ad08d (patch)
tree3445aca32104a30f00248a6658a8966f36166d89
downloadaur-334487845d8fa1acc0becb08a27096dbc75ad08d.tar.gz
1st publication
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98bd0f039b06
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = glade2script
+ pkgdesc = Glade interface engine for scripts.
+ pkgver = 3.2.4~ppa23
+ pkgrel = 1
+ arch = x86_64
+ arch = aarch64
+ arch = armv6h
+ arch = armv7h
+ arch = i686
+ license = custom
+ depends = glade2script-python3
+ options = !emptydirs
+ options = !strip
+ source = https://ftp5.gwdg.de/pub/linux/debian/mint/packages/pool/import/g/glade2script/glade2script_3.2.4~ppa23_all.deb
+ md5sums = SKIP
+ sha256sums = SKIP
+ sha512sums = SKIP
+
+pkgname = glade2script
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92890b5edd5c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: FraV1982 <consulenza dot vangi at outlook dot com>
+
+pkgname=glade2script
+pkgver=3.2.4~ppa23
+pkgrel=1
+pkgdesc="Glade interface engine for scripts."
+arch=(x86_64 aarch64 armv6h armv7h i686)
+url=""
+license=('custom')
+depends=('glade2script-python3')
+options=("!emptydirs" "!strip")
+
+_debname=glade2script_3.2.4~ppa23_all.deb
+
+source=(https://ftp5.gwdg.de/pub/linux/debian/mint/packages/pool/import/g/glade2script/glade2script_3.2.4~ppa23_all.deb)
+md5sums=('SKIP')
+sha256sums=('SKIP')
+sha512sums=('SKIP')
+
+prepare() {
+ cd "$srcdir"
+ msg2 "Decompressing Debian package glade2script..."
+ ar xv "${_debname}" > /dev/null
+ tar -xf data.tar.xz > /dev/null
+
+ find ./usr -type d -exec chmod 755 '{}' \;
+}
+
+package() {
+ cd "$srcdir"
+ cp -dpr --no-preserve=ownership {usr} "$pkgdir"
+}