summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122024-05-26 14:12:46 +0200
committerwillemw122024-05-26 14:12:46 +0200
commitf2dcfab03791c8c00514deac5b906125a9701d1a (patch)
tree1b670bb9ce04f90a2d399fa7f192111615370370
parent2d982bb266cc543dae0cb3bca3603119b9951e5a (diff)
downloadaur-f2dcfab03791c8c00514deac5b906125a9701d1a.tar.gz
Download from the master branch (and set an up-to-date package version)
Cleanup.
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD51
2 files changed, 44 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e41908664324..62cb60eee46d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,35 @@
pkgbase = glances-git
- pkgdesc = CLI curses-based monitoring tool (git)
- pkgver = 3.4.0.5.r724.gc187c14
+ pkgdesc = CLI curses-based monitoring tool
+ pkgver = 4.0.7.r0.gb1b8ea6
pkgrel = 1
url = https://github.com/nicolargo/glances
arch = any
license = LGPL-3.0-or-later
+ makedepends = git
makedepends = python-setuptools
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
- makedepends = git
- depends = python
- depends = python-psutil
- depends = python-future
depends = python-defusedxml
- depends = python-ujson
- depends = python-pydantic
+ depends = python-future
depends = python-packaging
depends = python-orjson
+ depends = python-psutil
+ depends = python-ujson
+ depends = python-pydantic
optdepends = hddtemp: HDD temperature monitoring support
- optdepends = uvicorn: for WebUI / RestFull API
- optdepends = python-jinja: for WebUI / RestFull API
- optdepends = python-fastapi: for WebUI / RestFull API
optdepends = python-docker: for the Docker monitoring support
+ optdepends = python-fastapi: for WebUI / RestFull API
+ optdepends = python-jinja: for WebUI / RestFull API
optdepends = python-matplotlib: for graphical/chart support
optdepends = python-netifaces: for the IP plugin
- optdepends = python-zeroconf: for the autodiscover mode
- optdepends = python-pystache: templating engine
optdepends = python-prometheus_client: for the Prometheus export module
+ optdepends = python-pystache: templating engine
+ optdepends = python-zeroconf: for the autodiscover mode
+ optdepends = uvicorn: for WebUI / RestFull API
provides = glances
conflicts = glances
- source = git+https://github.com/nicolargo/glances.git
+ source = glances-git::git+https://github.com/nicolargo/glances.git#branch=master
source = glances.service
sha512sums = SKIP
sha512sums = 49f0d185a37a5c5837e5beb463770c943ede40b2f1b8405e338129e897e97d9fc58373a8586fabc506266e6343cfea3c91b9787ac6832cc97a1ab63d6ad058d4
diff --git a/PKGBUILD b/PKGBUILD
index 3a9065a2150c..bc657e5d1097 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,62 @@
-# Maintainer: katt <magunasu.b97@gmail.com>
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: katt <magunasu.b97@gmail.com>
# Contributor: Christian Rebischke <chris.rebischke@archlinux.org>
# Contributor: Sébastien Luttringer <seblu@archlinux.org>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Francois Boulogne <fboulogne at april dot org>
pkgname=glances-git
-pkgver=3.4.0.5.r724.gc187c14
+pkgver=4.0.7.r0.gb1b8ea6
pkgrel=1
-pkgdesc='CLI curses-based monitoring tool (git)'
+pkgdesc='CLI curses-based monitoring tool'
arch=(any)
url=https://github.com/nicolargo/glances
license=(LGPL-3.0-or-later)
-makedepends=(python-setuptools python-build python-installer python-wheel git)
-depends=(python python-psutil python-future python-defusedxml python-ujson python-pydantic python-packaging python-orjson)
+makedepends=(git python-setuptools python-build python-installer python-wheel)
+depends=(python-defusedxml python-future python-packaging python-orjson python-psutil python-ujson python-pydantic)
optdepends=('hddtemp: HDD temperature monitoring support'
- 'uvicorn: for WebUI / RestFull API'
- 'python-jinja: for WebUI / RestFull API'
- 'python-fastapi: for WebUI / RestFull API'
'python-docker: for the Docker monitoring support'
+ 'python-fastapi: for WebUI / RestFull API'
+ 'python-jinja: for WebUI / RestFull API'
'python-matplotlib: for graphical/chart support'
'python-netifaces: for the IP plugin'
- 'python-zeroconf: for the autodiscover mode'
+ 'python-prometheus_client: for the Prometheus export module'
'python-pystache: templating engine'
- 'python-prometheus_client: for the Prometheus export module')
-conflicts=("${pkgname%-git}")
+ 'python-zeroconf: for the autodiscover mode'
+ 'uvicorn: for WebUI / RestFull API')
provides=("${pkgname%-git}")
-source=(git+"${url}".git
+conflicts=("${pkgname%-git}")
+#source=("$pkgname::git+$url.git"
+source=("$pkgname::git+$url.git#branch=master"
glances.service)
sha512sums=('SKIP'
'49f0d185a37a5c5837e5beb463770c943ede40b2f1b8405e338129e897e97d9fc58373a8586fabc506266e6343cfea3c91b9787ac6832cc97a1ab63d6ad058d4')
+# For default 'develop' branch
+#pkgver() {
+# local _tag
+#
+# cd $pkgname
+# _tag="$(git tag | sort --version-sort | tail -1)"
+# printf "%s.r%s.%s" "$(echo -n "$_tag" | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g')" "$(git rev-list --count "$_tag"..HEAD)" "$(git rev-parse --short=7 "$_tag")"
+#}
+
pkgver() {
- git -C "${pkgname%-git}" describe --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git -C $pkgname describe --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- # Clean out old wheels etc.
- git -C "${pkgname%-git}" clean -dfx
+ git -C $pkgname clean -dfx
}
build() {
- cd "${pkgname%-git}"
- python -m build --wheel --no-isolation
+ cd $pkgname
+ python -m build --wheel --no-isolation
}
package() {
- cd "${pkgname%-git}"
- python -m installer --destdir="$pkgdir" dist/*.whl
- install -Dm644 "${srcdir}"/glances.service -t "${pkgdir}"/usr/lib/systemd/system
+ install -Dm644 glances.service -t "$pkgdir/usr/lib/systemd/system"
+
+ cd $pkgname
+ python -m installer --destdir="$pkgdir" dist/*.whl
}