summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2016-08-24 06:11:23 +0300
committerAnton Leontiev2016-08-24 06:11:23 +0300
commita560798977e8608fb467f92bb097fa59241d4fb7 (patch)
tree859546f2dfce48dbad3338866dcce134784c9649
parent782be49792bb40f97f7214a8fabe9790e9850c99 (diff)
downloadaur-a560798977e8608fb467f92bb097fa59241d4fb7.tar.gz
Update to v4.2.5
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD66
-rw-r--r--gle-graphics-4.2.4c-libloader.patch12
-rw-r--r--gle-graphics-4.2.4c-non-ascii.patch27
-rw-r--r--gle-graphics-4.2.4c-transperancy.patch17
-rw-r--r--gle-graphics.install13
6 files changed, 38 insertions, 119 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5722eb2f16e4..e3a2547a2ee0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
+# Generated by mksrcinfo v8
+# Wed Aug 24 03:10:14 UTC 2016
pkgbase = gle-graphics
pkgdesc = Graphics scripting language for creating graphs, plots, diagrams and figures
- pkgver = 4.2.4c
- pkgrel = 3
+ pkgver = 4.2.5
+ pkgrel = 1
url = http://www.gle-graphics.org/
- install = gle-graphics.install
arch = i686
arch = x86_64
+ arch = armv7h
license = BSD
license = GPL
makedepends = qt4
@@ -17,18 +19,12 @@ pkgbase = gle-graphics
makedepends = texlive-latexextra
depends = libtiff
depends = libjpeg
- depends = libpng15
depends = ghostscript
- optdepends = texlive: latex labels in gle scripts
+ depends = poppler-glib
+ optdepends = texlive: latex labels in GLE scripts
optdepends = qt4: qgle
- source = http://prdownloads.sourceforge.net/glx/gle-graphics-4.2.4cf-src.tar.gz
- source = gle-graphics-4.2.4c-libloader.patch
- source = gle-graphics-4.2.4c-transperancy.patch
- source = gle-graphics-4.2.4c-non-ascii.patch
- md5sums = 5eef0a63ee0077237b8a36fe1a24407f
- md5sums = 92f81bd634975bb96154ebfc2337629e
- md5sums = cecfbdf3d18390485a8a963448fd55aa
- md5sums = 2196ee0a27645b764ac84f59957c79f3
+ source = http://prdownloads.sourceforge.net/glx/gle-graphics-4.2.5f-src.tar.gz
+ md5sums = c28c17aa8448822667604631ec7c8629
pkgname = gle-graphics
diff --git a/PKGBUILD b/PKGBUILD
index 8964428bfaba..945e288ff80b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,43 @@
-# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Contributor: Anton Leontiev <scileont /at/ gmail.com>
# Contributor: B. Lee <darklin20 /at/ gmail.com>
+# Contributor: jerry73204 <jerry73204 /at/ gmail.com>
pkgname=gle-graphics
-pkgver=4.2.4c
-pkgrel=3
-arch=('i686' 'x86_64')
+pkgver=4.2.5
+pkgrel=1
+arch=('i686' 'x86_64' 'armv7h')
pkgdesc='Graphics scripting language for creating graphs, plots, diagrams and figures'
url='http://www.gle-graphics.org/'
license=('BSD' 'GPL')
-depends=('libtiff' 'libjpeg' 'libpng15' 'ghostscript')
-makedepends=('qt4' 'openssl' 'zlib' 'ghostscript' 'texlive-bin' 'texlive-core' 'texlive-latexextra')
-optdepends=('texlive: latex labels in gle scripts' 'qt4: qgle')
-source=(http://prdownloads.sourceforge.net/glx/gle-graphics-${pkgver}f-src.tar.gz
- gle-graphics-$pkgver-libloader.patch
- gle-graphics-$pkgver-transperancy.patch
- gle-graphics-$pkgver-non-ascii.patch)
-install=gle-graphics.install
-md5sums=('5eef0a63ee0077237b8a36fe1a24407f'
- '92f81bd634975bb96154ebfc2337629e'
- 'cecfbdf3d18390485a8a963448fd55aa'
- '2196ee0a27645b764ac84f59957c79f3')
-
-# I didn't split building into build() and package() because it works
-# incorrectly with gle-graphics. And I don't know why!!
+depends=('libtiff' 'libjpeg' 'ghostscript' 'poppler-glib')
+makedepends=('qt4' 'openssl' 'zlib' 'ghostscript' 'texlive-bin' 'texlive-core' 'texlive-latexextra')
+optdepends=('texlive: latex labels in GLE scripts' 'qt4: qgle')
+source=(http://prdownloads.sourceforge.net/glx/gle-graphics-${pkgver}f-src.tar.gz)
+md5sums=('c28c17aa8448822667604631ec7c8629')
-build() {
- cd $srcdir/$pkgname-$pkgver
+prepare() {
+ cd $pkgname-$pkgver
- unset MAKEFLAGS
- sed -i -e 's:GLE_INSTALL_DATA=$prefix/share/$PACKAGE_TARNAME/$GLE_VERSION:GLE_INSTALL_DATA=$prefix/share/$PACKAGE_TARNAME:' configure
+ #sed -i -e 's:GLE_INSTALL_DATA=$prefix/share/$PACKAGE_TARNAME/$GLE_VERSION:GLE_INSTALL_DATA=$prefix/share/$PACKAGE_TARNAME:' configure
+}
-# patch -p1 -i $srcdir/gle-graphics-$pkgver-libloader.patch
- patch -p1 -i $srcdir/gle-graphics-$pkgver-transperancy.patch
- patch -p1 -i $srcdir/gle-graphics-$pkgver-non-ascii.patch
+build() {
+ cd $pkgname-$pkgver
- ./configure --prefix=/usr --with-qt --with-jpeg --with-png --with-tiff --with-z \
- --with-manip --with-libgle --with-rpath=no --with-extrafonts --with-x
+ CPPFLAGS+=' -O2' ./configure --prefix=/usr --with-qt --with-jpeg \
+ --with-png --with-tiff --with-z --with-manip --with-libgle \
+ --with-rpath=no --with-extrafonts --with-x
- make
+ make -j1
+ make -j1 doc
+}
- # Add just compiled GLE to path in order to build documentation
- set PATH=$PATH:$srcdir/$pkgname-$pkgver/build/bin
- make doc
+package() {
+ cd $pkgname-$pkgver
- make DESTDIR=$pkgdir install
+ make -j1 DESTDIR="$pkgdir" install
- install -D -m644 LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
- install -D -m644 platform/autopackage/gle.png $pkgdir/usr/share/icons/hicolor/48x48/apps/gle.png
- install -D -m644 platform/autopackage/gle.xml $pkgdir/usr/share/mime/packages/gle.xml
- install -D -m644 platform/autopackage/gle.desktop $pkgdir/usr/share/applications/gle.desktop
+ install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 platform/autopackage/gle.png "$pkgdir/usr/share/icons/hicolor/48x48/apps/gle.png"
+ install -D -m644 platform/autopackage/gle.xml "$pkgdir/usr/share/mime/packages/gle.xml"
+ install -D -m644 platform/autopackage/gle.desktop "$pkgdir/usr/share/applications/gle.desktop"
}
diff --git a/gle-graphics-4.2.4c-libloader.patch b/gle-graphics-4.2.4c-libloader.patch
deleted file mode 100644
index 036ea9b0c660..000000000000
--- a/gle-graphics-4.2.4c-libloader.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -rau gle-graphics-4.2.4c/src/gui/qgslibloader.cpp gle-graphics-4.2.4c-pathed/src/gui/qgslibloader.cpp
---- gle-graphics-4.2.4c/src/gui/qgslibloader.cpp 2012-02-19 21:07:34.000000000 +0000
-+++ gle-graphics-4.2.4c-pathed/src/gui/qgslibloader.cpp 2012-08-08 17:56:27.574528844 +0000
-@@ -279,7 +279,7 @@
- libloc.append("/Ghostscript");
- }
- QByteArray strdata = libloc.toLatin1();
-- hmodule = dlopen(strdata.constData(), RTLD_NOW);
-+ hmodule = dlopen(strdata.constData(), RTLD_NOW | RTLD_DEEPBIND);
- }
- /* Error message if loading fails */
- if (hmodule == NULL) {
diff --git a/gle-graphics-4.2.4c-non-ascii.patch b/gle-graphics-4.2.4c-non-ascii.patch
deleted file mode 100644
index 325ffa071bcf..000000000000
--- a/gle-graphics-4.2.4c-non-ascii.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -bruN a/src/gle/tex.cpp b/src/gle/tex.cpp
---- a/src/gle/tex.cpp 2012-01-14 23:46:06.000000000 +0900
-+++ b/src/gle/tex.cpp 2013-07-07 01:00:23.397705896 +0900
-@@ -399,11 +399,11 @@
- for (i=0;i<npm;i++) {
- pm[i] = in;
- pmlen[i] = 0;
-- if (chr_code[(unsigned int)*in]==7) { /* begin group */
-+ if (chr_code[(unsigned int)*(uchar*)in]==7) { /* begin group */
- pm[i] = ++in;
- for (;*in!=0;in++) {
-- if (chr_code[(unsigned int)*in]==7) gcnt++;
-- if (chr_code[(unsigned int)*in]==8) {
-+ if (chr_code[(unsigned int)*(uchar*)in]==7) gcnt++;
-+ if (chr_code[(unsigned int)*(uchar*)in]==8) {
- if (gcnt==0) break;
- gcnt--;
- }
-@@ -411,7 +411,7 @@
- pmlen[i] = in - pm[i];
- in++;
- } else {
-- if (chr_code[(unsigned int)*in]==6) { /* backslash look for non-alpha */
-+ if (chr_code[(unsigned int)*(uchar*)in]==6) { /* backslash look for non-alpha */
- pm[i] = ++in;
- if (isalpha(*pm[i])) {
- for (;*in!=0;in++) {
diff --git a/gle-graphics-4.2.4c-transperancy.patch b/gle-graphics-4.2.4c-transperancy.patch
deleted file mode 100644
index 3dda78d954aa..000000000000
--- a/gle-graphics-4.2.4c-transperancy.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/src/gle/gle-poppler.cpp b/src/gle/gle-poppler.cpp
-index cde6b8f..3b04d75 100644
---- a/src/gle/gle-poppler.cpp
-+++ b/src/gle/gle-poppler.cpp
-@@ -330,9 +330,9 @@ void gle_convert_pdf_to_image(char* pdfData,
- int i_width = gle_round_int(width / PS_POINTS_PER_INCH * resolution);
- int i_height = gle_round_int(height / PS_POINTS_PER_INCH * resolution);
- cairo_format_t format = CAIRO_FORMAT_RGB24;
-- if ((options & GLE_OUTPUT_OPTION_TRANSPARENT) != 0 && device == GLE_DEVICE_PNG) {
-- format = CAIRO_FORMAT_ARGB32;
-- }
-+// if ((options & GLE_OUTPUT_OPTION_TRANSPARENT) != 0 && device == GLE_DEVICE_PNG) {
-+// format = CAIRO_FORMAT_ARGB32;
-+// }
- cairo_surface_t* surface = cairo_image_surface_create(format, i_width, i_height);
- cairo_t* cr = cairo_create(surface);
- if (format == CAIRO_FORMAT_RGB24) {
diff --git a/gle-graphics.install b/gle-graphics.install
deleted file mode 100644
index 62b7f879db86..000000000000
--- a/gle-graphics.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- [ -x /usr/bin/update-desktop-database ] && /usr/bin/update-desktop-database -q
- [ -x /usr/bin/gtk-update-icon-cache ] && gtk-update-icon-cache -q -f -t usr/share/icons/hicolor
- [ -x /usr/bin/update-mime-database ] && update-mime-database usr/share/mime
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}