summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKokaKiwi2020-03-01 22:28:15 +0100
committerKokaKiwi2020-03-01 22:28:15 +0100
commitc47d9da729b2b3f82c2c5b7a7f9ebe7dcca88e96 (patch)
tree0272722c4bcb75ad7699d8881a3720ef69bb7134
downloadaur-c47d9da729b2b3f82c2c5b7a7f9ebe7dcca88e96.tar.gz
Initial commit.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68e2cf24aff8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gleam-git
+ pkgdesc = A statically typed language for the Erlang VM
+ pkgver = 0.7.0.r0.ga89f777
+ pkgrel = 1
+ url = https://github.com/gleam-lang/gleam
+ arch = x86_64
+ license = Apache
+ makedepends = rust
+ depends = erlang-nox
+ provides = gleam
+ conflicts = gleam
+ options = strip
+ options = !docs
+ options = !libtool
+ options = !staticlibs
+ source = gleam::git://github.com/gleam-lang/gleam.git
+ sha256sums = SKIP
+
+pkgname = gleam-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e35bdebecc62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: KokaKiwi <kokakiwi+aur@kokakiwi.net>
+
+pkgname=gleam-git
+pkgver=0.7.0.r0.ga89f777
+pkgrel=1
+pkgdesc="A statically typed language for the Erlang VM"
+arch=('x86_64')
+license=('Apache')
+url='https://github.com/gleam-lang/gleam'
+makedepends=('rust')
+depends=('erlang-nox')
+provides=('gleam')
+conflicts=('gleam')
+options=(strip !docs !libtool !staticlibs)
+source=('gleam::git://github.com/gleam-lang/gleam.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "gleam"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "gleam"
+
+ cargo build --release
+}
+
+check() {
+ cd "gleam"
+
+ cargo test
+}
+
+package() {
+ cd "gleam"
+
+ install -Dm0755 target/release/gleam "${pkgdir}"/usr/bin/gleam
+}