summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2019-11-26 18:47:56 +0200
committerMartino Pilia2019-11-26 18:47:56 +0200
commit4aea2ec1a3b84b887bd2a80bbb910137b71a61f2 (patch)
tree40c2bede2c96b2813d99ddfee61692956142e53e
downloadaur-4aea2ec1a3b84b887bd2a80bbb910137b71a61f2.tar.gz
Package submission
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebab80a3d7bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = glew-2.0
+ pkgdesc = The OpenGL Extension Wrangler Library
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = http://glew.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = BSD
+ license = MIT
+ license = GPL
+ depends = libxmu
+ depends = libxi
+ depends = glu
+ source = http://downloads.sourceforge.net/glew/glew-2.0.0.tgz
+ sha1sums = 6e15c84f7e1fad34cd3679f784a233744ddf048f
+
+pkgname = glew-2.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61511d6ea8cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer of this PKGBUILD file: Martino Pilia <martino.pilia@gmail.com>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: SleepyDog
+
+_name=glew
+pkgname="${_name}-2.0"
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="The OpenGL Extension Wrangler Library"
+arch=('i686' 'x86_64')
+url="http://glew.sourceforge.net"
+license=('BSD' 'MIT' 'GPL')
+depends=('libxmu' 'libxi' 'glu')
+source=("http://downloads.sourceforge.net/${_name}/${_name}-${pkgver}.tgz")
+sha1sums=('6e15c84f7e1fad34cd3679f784a233744ddf048f')
+
+build() {
+ cd ${_name}-${pkgver}
+
+ sed -i 's|lib64|lib|' config/Makefile.linux
+ sed -i '/^.PHONY: .*\.pc$/d' Makefile
+ make
+}
+
+package() {
+ cd ${_name}-${pkgver}
+ make GLEW_DEST="${pkgdir}/usr" install.all
+ rm -rf "${pkgdir:?}/usr/bin"
+ mkdir "${pkgdir}/usr/include/GL/glew2.0"
+ mv "${pkgdir}/usr/include/GL"/*.h "${pkgdir}/usr/include/GL/glew2.0"/.
+ mv "${pkgdir}/usr/lib/pkgconfig/glew.pc" "${pkgdir}/usr/lib/pkgconfig/glew-2.0.pc"
+ mv "${pkgdir}/usr/lib/libGLEW.so" "${pkgdir}/usr/lib/libGLEW2.0.so"
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}