summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2021-03-10 11:48:10 +0100
committerAlexander F. Rødseth2021-03-10 11:48:10 +0100
commitc6490910708c37a8ea4024d897bf429ce6b0e01f (patch)
tree94521573b8bf1ce21a41446b413154115a2984dc
downloadaur-c6490910708c37a8ea4024d897bf429ce6b0e01f.tar.gz
Moving glew-wayland from [community] to AUR
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04b4e45eab20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = glew-wayland
+ pkgdesc = The OpenGL Extension Wrangler Library, for Wayland
+ pkgver = 2.2.0
+ pkgrel = 1
+ url = https://glew.sourceforge.net/
+ arch = x86_64
+ license = BSD
+ license = GPL
+ license = MIT
+ depends = glu
+ depends = libxi
+ depends = libxmu
+ conflicts = glew
+ source = https://downloads.sourceforge.net/glew/glew-2.2.0.tgz
+ sha256sums = d4fc82893cfb00109578d0a1a2337fb8ca335b3ceccf97b97e5cc7f08e4353e1
+
+pkgname = glew-wayland
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..851f45f80764
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer:
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: SleepyDog
+# Contributor: duck <duck@vmail.me>
+
+pkgname=glew-wayland
+pkgver=2.2.0
+pkgrel=1
+pkgdesc='The OpenGL Extension Wrangler Library, for Wayland'
+arch=(x86_64)
+url='https://glew.sourceforge.net/'
+license=(BSD GPL MIT)
+depends=(glu libxi libxmu)
+conflicts=(glew)
+source=("https://downloads.sourceforge.net/glew/glew-$pkgver.tgz")
+sha256sums=('d4fc82893cfb00109578d0a1a2337fb8ca335b3ceccf97b97e5cc7f08e4353e1')
+
+prepare() {
+ cd glew-$pkgver
+ sed -i '/^.PHONY: .*\.pc$/d' Makefile
+ sed -i 's,lib64,lib,' config/Makefile.linux
+}
+
+build() {
+ make STRIP= SYSTEM=linux-egl -C glew-$pkgver
+}
+
+package_glew-wayland() {
+ cd glew-$pkgver
+ make GLEW_DEST="$pkgdir/usr" SYSTEM=linux-egl install.all
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}