summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConnor Behan2020-11-29 14:13:31 +0000
committerConnor Behan2020-11-29 14:13:31 +0000
commit5acb9bb18329f714c6a3178f798a9edb5ddd8682 (patch)
tree2f123d33302bd8a39347502f62b0a60173bd9840
parentd05ceb7d58806e28753b67b795fcf57f418fd107 (diff)
downloadaur-5acb9bb18329f714c6a3178f798a9edb5ddd8682.tar.gz
Add ARM flags
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3b376eb1d80..ad4c21a8b1d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,7 @@ pkgbase = glib
url = http://www.gtk.org/
arch = i686
arch = x86_64
+ arch = armv6h
license = LGPL
depends = glibc
depends = sh
diff --git a/PKGBUILD b/PKGBUILD
index 3690a430dfd8..5a4c35a1e346 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=glib
pkgver=1.2.10
pkgrel=15
pkgdesc="Common C routines used by Gtk+ and other libs"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv6h')
url="http://www.gtk.org/"
license=('LGPL')
depends=('glibc' 'sh')
@@ -31,6 +31,8 @@ build() {
CONFIGFLAG='--host=i686-pc-linux-gnu --target=i686-pc-linux-gnu'
elif [[ $CARCH = "x86_64" ]]; then
CONFIGFLAG='--host=x86_64-unknown-linux-gnu --target=x86_64-unknown-linux-gnu'
+ elif [[ $CARCH = "armv6h" ]]; then
+ CONFIGFLAG='--host=armv6l-unknown-linux-gnueabihf --target=armv6l-unknown-linux-gnueabihf'
fi
autoreconf --force --install