summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-06-10 22:40:44 -0400
committerSolomon Choina2018-06-10 22:40:44 -0400
commit08f7c54d7872e30c56807a7eb081b128296bdb24 (patch)
treea2647419b3a1f0ce5fd02fb8e9f441ea0bf11585
parent4eac3b42981a94d206acf7331050ad32c1832dca (diff)
downloadaur-08f7c54d7872e30c56807a7eb081b128296bdb24.tar.gz
adding the hooks and did a rewrite of some stuff
-rw-r--r--.SRCINFO51
-rw-r--r--0001-noisy-glib-compile-schemas.patch37
-rw-r--r--PKGBUILD97
-rw-r--r--gio-querymodules.hook11
-rw-r--r--glib-compile-schemas.hook12
-rw-r--r--glib2.csh1
-rw-r--r--glib2.sh1
7 files changed, 152 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bac4374309f8..ff9d552d5cb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,41 @@
-# Generated by mksrcinfo v8
-# Sun Jul 3 09:17:22 UTC 2016
pkgbase = glib2-git
- pkgdesc = Common C routines used by GTK+ 2.4 and other libs
- pkgver = 2.49.2.20.g27fad7a
+ pkgdesc = Low Level Core Library
+ pkgver = 2.57.1.180.ge22bffb52
pkgrel = 1
- url = http://git.gnome.org/browse/glib/tree/README.in
- arch = i686
+ url = https://wiki.gnome.org/Projects/GLib
arch = x86_64
- license = GPL2
+ license = LGPL2.1
+ checkdepends = desktop-file-utils
+ makedepends = gettext
makedepends = gtk-doc
+ makedepends = shared-mime-info
+ makedepends = python
+ makedepends = libelf
makedepends = git
- depends = elfutils
- depends = python
- provides = glib2=2.49.2.20.g27fad7a
- conflicts = glib2
+ makedepends = util-linux
+ makedepends = dbus
+ depends = pcre
+ depends = libffi
+ depends = libutil-linux
+ depends = zlib
+ optdepends = python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report
+ optdepends = libelf: gresource inspection tool
options = !emptydirs
- options = !libtool
- source = glib2-git::git://git.gnome.org/glib
- source = glib2.sh
- source = glib2.csh
- sha256sums = SKIP
- sha256sums = 9456872cdedcc639fb679448d74b85b0facf81033e27157d2861b991823b5a2a
- sha256sums = 8d5626ffa361304ad3696493c0ef041d0ab10c857f6ef32116b3e2878ecf89e3
+ source = git+https://gitlab.gnome.org/GNOME/glib.git
+ source = 0001-noisy-glib-compile-schemas.patch
+ source = glib-compile-schemas.hook
+ source = gio-querymodules.hook
sha512sums = SKIP
- sha512sums = dca2bc74d2013fcb24145ac794eef457aa3213c039e40a1a26ca5017694930768e7c80e334e17a56834549dff6549c781ddd91fae6c7bbb26fdd6a083ad8217a
- sha512sums = c3899eb7fa5482ce8a35fe02db90fd0f928d50aa7e4365a9529ef35a2dcd1ed86d5a24f6bc5c635ef5b2d95a0ebfebc2bb6bc90404c99f6fb7484ed2fa032c06
+ sha512sums = ddbf4a8eaf60e943a10a1ad67f2de078143558df8cc06e8009da87d8068af0cf8c66f443474b8b2848239c003e6210ff9ceb1ba5ffda1b95b80687adbf813722
+ sha512sums = c04fe25afc217c295b5ce4034733cec046126482d00fb8d0299e4815ac57129dd3f1c9ac824b9386d208a4f113e9dae682ea5b72f75387ed6b6b96a9cbbee8ca
+ sha512sums = 5afd6f275c8fff16df3e685818f2e7989b39ffb3b8f5fc261a5a6d54a9b28ef53af62f3bf5067cf87cb74691572f85730cbc508691956ae048a0f3ecc1a0a39c
pkgname = glib2-git
+pkgname = glib2-docs-git
+ pkgdesc = Documentation for GLib
+ license = LGPL2.1
+ license = custom
+ depends =
+ optdepends =
+
diff --git a/0001-noisy-glib-compile-schemas.patch b/0001-noisy-glib-compile-schemas.patch
new file mode 100644
index 000000000000..841b43e06955
--- /dev/null
+++ b/0001-noisy-glib-compile-schemas.patch
@@ -0,0 +1,37 @@
+From 6474cf310a2b64e7cb911e74b4dc9456f1d7930c Mon Sep 17 00:00:00 2001
+From: Solomon Choina <shlomochoina@gmail.com>
+Date: Sun, 10 Jun 2018 21:51:38 -0400
+Subject: [PATCH] noisy-glib-compile-schemas
+
+---
+ gio/glib-compile-schemas.c | 17 ++---------------
+ 1 file changed, 2 insertions(+), 15 deletions(-)
+
+diff --git a/gio/glib-compile-schemas.c b/gio/glib-compile-schemas.c
+index f6e1b4036..d16b26fe1 100644
+--- a/gio/glib-compile-schemas.c
++++ b/gio/glib-compile-schemas.c
+
+@@ -1223,19 +1223,6 @@ parse_state_start_schema (ParseState *state,
+ return;
+ }
+
+- if (path && (g_str_has_prefix (path, "/apps/") ||
+- g_str_has_prefix (path, "/desktop/") ||
+- g_str_has_prefix (path, "/system/")))
+- {
+- gchar *message = NULL;
+- message = g_strdup_printf (_("Warning: Schema “%s” has path “%s”. "
+- "Paths starting with "
+- "“/apps/”, “/desktop/” or “/system/” are deprecated."),
+- id, path);
+- g_printerr ("%s\n", message);
+- g_free (message);
+- }
+-
+ state->schema_state = schema_state_new (path, gettext_domain,
+ extends, extends_name, list_of);
+
+--
+2.17.1
+
diff --git a/PKGBUILD b/PKGBUILD
index fa033a7e2cb5..be7c97f8ada2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,58 +2,83 @@
# Contributor: Yichao Yu <yyc1992@gmail.com>
# Contributor: kfgz <kfgz@interia.pl>
-_pkgname=glib2
-pkgname=$_pkgname-git
-pkgver=2.49.2.20.g27fad7a
+pkgbase=glib2-git
+_pkgame=glib2
+pkgname=(glib2-git glib2-docs-git)
+pkgver=2.57.1.180.ge22bffb52
pkgrel=1
-pkgdesc="Common C routines used by GTK+ 2.4 and other libs"
-arch=(i686 x86_64)
-url=http://git.gnome.org/browse/glib/tree/README.in
-license=(GPL2)
-depends=(elfutils python)
-makedepends=(gtk-doc git)
-provides=($_pkgname=$pkgver)
+pkgdesc="Low Level Core Library"
+arch=('x86_64')
+url="https://wiki.gnome.org/Projects/GLib"
+license=(LGPL2.1)
+depends=(pcre libffi libutil-linux zlib)
+makedepends=(gettext gtk-doc shared-mime-info python libelf git util-linux dbus)
+checkdepends=(desktop-file-utils)
+optdepends=('python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report'
+ 'libelf: gresource inspection tool')
conflicts=($_pkgname)
-options=(!emptydirs !libtool)
-source=($pkgname::git://git.gnome.org/glib
- $_pkgname.sh
- $_pkgname.csh)
-sha256sums=('SKIP'
- '9456872cdedcc639fb679448d74b85b0facf81033e27157d2861b991823b5a2a'
- '8d5626ffa361304ad3696493c0ef041d0ab10c857f6ef32116b3e2878ecf89e3')
+options=(!emptydirs)
+source=("git+https://gitlab.gnome.org/GNOME/glib.git"
+ 0001-noisy-glib-compile-schemas.patch
+ glib-compile-schemas.hook
+ gio-querymodules.hook )
sha512sums=('SKIP'
- 'dca2bc74d2013fcb24145ac794eef457aa3213c039e40a1a26ca5017694930768e7c80e334e17a56834549dff6549c781ddd91fae6c7bbb26fdd6a083ad8217a'
- 'c3899eb7fa5482ce8a35fe02db90fd0f928d50aa7e4365a9529ef35a2dcd1ed86d5a24f6bc5c635ef5b2d95a0ebfebc2bb6bc90404c99f6fb7484ed2fa032c06')
+ 'ddbf4a8eaf60e943a10a1ad67f2de078143558df8cc06e8009da87d8068af0cf8c66f443474b8b2848239c003e6210ff9ceb1ba5ffda1b95b80687adbf813722'
+ 'c04fe25afc217c295b5ce4034733cec046126482d00fb8d0299e4815ac57129dd3f1c9ac824b9386d208a4f113e9dae682ea5b72f75387ed6b6b96a9cbbee8ca'
+ '5afd6f275c8fff16df3e685818f2e7989b39ffb3b8f5fc261a5a6d54a9b28ef53af62f3bf5067cf87cb74691572f85730cbc508691956ae048a0f3ecc1a0a39c')
pkgver() {
- cd $pkgname/
- git describe | sed 's/-/./g'
+ cd glib
+ git describe --tags | sed 's/-/./g'
}
prepare() {
- cd $pkgname/
- touch gtk-doc.make
- sed -i '1i\EXTRA_DIST=""\nCLEANFILES=""\n' docs/reference/{gio,gobject,glib}/Makefile.am
-}
+ cd $srcdir/glib
+ # Suppress noise from glib-compile-schemas.hook
+ patch -Np1 -i ../0001-noisy-glib-compile-schemas.patch
+
+ NOCONFIGURE=1 ./autogen.sh
+ }
-build() {
- cd $pkgname/
- touch README
- autoreconf -fi
+build () {
+ local debug=minimum
+ check_option debug y && debug=yes
+
+ cd "$srcdir/glib"
./configure \
--prefix=/usr \
--libdir=/usr/lib \
--sysconfdir=/etc \
--with-pcre=system \
- --disable-fam
+ --disable-fam \
+ --enable-gtk-doc \
+ --enable-debug=$debug
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
-package() {
+check() {
+ cd "$srcdir/glib"
+ make check
+}
+
+package_glib2-git() {
+ cd "$srcdir/glib"
make -C $pkgname DESTDIR="$pkgdir" install
- for i in $_pkgname.{,c}sh; do
- install -Dm755 $i "$pkgdir"/etc/profile.d/$i
- done
- find "$pkgdir"/usr/share/bash-completion/completions/ -type f -exec chmod -x '{}' \;
- sed -i 's:^#!/usr/bin/env python$:&2:g' "$pkgdir"/usr/bin/gdbus-codegen
+ mv "$pkgdir/usr/share/gtk-doc" "$srcdir"
+
+ install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 ../*.hook
}
+
+package_glib2-docs-git() {
+ pkgdesc="Documentation for GLib"
+ depends=()
+ optdepends=()
+ license+=(custom)
+
+ mkdir -p "$pkgdir/usr/share"
+ mv gtk-doc "$pkgdir/usr/share"
+
+ install -Dt "$pkgdir/usr/share/licenses/glib2-docs" -m644 glib/docs/reference/COPYING
+}
+
diff --git a/gio-querymodules.hook b/gio-querymodules.hook
new file mode 100644
index 000000000000..193233398168
--- /dev/null
+++ b/gio-querymodules.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/lib/gio/modules/*.so
+
+[Action]
+Description = Updating GIO module cache...
+When = PostTransaction
+Exec = /usr/bin/gio-querymodules /usr/lib/gio/modules
diff --git a/glib-compile-schemas.hook b/glib-compile-schemas.hook
new file mode 100644
index 000000000000..04dc59b1a638
--- /dev/null
+++ b/glib-compile-schemas.hook
@@ -0,0 +1,12 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/share/glib-2.0/schemas/*.gschema.xml
+Target = usr/share/glib-2.0/schemas/*.gschema.override
+
+[Action]
+Description = Compiling GSettings XML schema files...
+When = PostTransaction
+Exec = /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
diff --git a/glib2.csh b/glib2.csh
deleted file mode 100644
index 7aa3a2ffae57..000000000000
--- a/glib2.csh
+++ /dev/null
@@ -1 +0,0 @@
-setenv G_BROKEN_FILENAMES 1
diff --git a/glib2.sh b/glib2.sh
deleted file mode 100644
index 96a056e1e608..000000000000
--- a/glib2.sh
+++ /dev/null
@@ -1 +0,0 @@
-export G_BROKEN_FILENAMES=1