summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-06-11 10:14:17 -0400
committerSolomon Choina2018-06-11 10:14:17 -0400
commit5f274144a17a707e0a578c5189d748998947426b (patch)
tree12d39ea9c1b9851f4bf8146c61d6fbef8e160e75
parent08f7c54d7872e30c56807a7eb081b128296bdb24 (diff)
downloadaur-5f274144a17a707e0a578c5189d748998947426b.tar.gz
moving to meson
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD33
2 files changed, 21 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff9d552d5cb4..ec8ae836a237 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = glib2-git
pkgdesc = Low Level Core Library
- pkgver = 2.57.1.180.ge22bffb52
+ pkgver = 2.57.1.203.g8bbc38b49
pkgrel = 1
url = https://wiki.gnome.org/Projects/GLib
arch = x86_64
license = LGPL2.1
checkdepends = desktop-file-utils
+ makedepends = meson
+ makedepends = ninja
makedepends = gettext
makedepends = gtk-doc
makedepends = shared-mime-info
@@ -20,6 +22,7 @@ pkgbase = glib2-git
depends = zlib
optdepends = python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report
optdepends = libelf: gresource inspection tool
+ provides = glib2=2.57.1.203.g8bbc38b49
options = !emptydirs
source = git+https://gitlab.gnome.org/GNOME/glib.git
source = 0001-noisy-glib-compile-schemas.patch
@@ -38,4 +41,6 @@ pkgname = glib2-docs-git
license = custom
depends =
optdepends =
+ provides = glib2-docs
+ conflicts = glib2-docs
diff --git a/PKGBUILD b/PKGBUILD
index be7c97f8ada2..0c8751de0590 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,18 +5,19 @@
pkgbase=glib2-git
_pkgame=glib2
pkgname=(glib2-git glib2-docs-git)
-pkgver=2.57.1.180.ge22bffb52
+pkgver=2.57.1.203.g8bbc38b49
pkgrel=1
pkgdesc="Low Level Core Library"
arch=('x86_64')
url="https://wiki.gnome.org/Projects/GLib"
license=(LGPL2.1)
depends=(pcre libffi libutil-linux zlib)
-makedepends=(gettext gtk-doc shared-mime-info python libelf git util-linux dbus)
+makedepends=(meson ninja gettext gtk-doc shared-mime-info python libelf git util-linux dbus)
checkdepends=(desktop-file-utils)
optdepends=('python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report'
'libelf: gresource inspection tool')
conflicts=($_pkgname)
+provides=(glib2=$pkgver)
options=(!emptydirs)
source=("git+https://gitlab.gnome.org/GNOME/glib.git"
0001-noisy-glib-compile-schemas.patch
@@ -37,7 +38,6 @@ prepare() {
# Suppress noise from glib-compile-schemas.hook
patch -Np1 -i ../0001-noisy-glib-compile-schemas.patch
- NOCONFIGURE=1 ./autogen.sh
}
build () {
@@ -45,26 +45,21 @@ build () {
check_option debug y && debug=yes
cd "$srcdir/glib"
- ./configure \
- --prefix=/usr \
- --libdir=/usr/lib \
- --sysconfdir=/etc \
- --with-pcre=system \
- --disable-fam \
- --enable-gtk-doc \
- --enable-debug=$debug
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
+ arch-meson build \
+ -Dfam=false \
+ -Dgtk_doc=true \
+ -Dselinux=false
+ ninja -C build
}
-check() {
- cd "$srcdir/glib"
- make check
-}
+#check() {internal_pcre
+# cd "$srcdir/glib"
+# make check
+#}
package_glib2-git() {
cd "$srcdir/glib"
- make -C $pkgname DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C build install
mv "$pkgdir/usr/share/gtk-doc" "$srcdir"
install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 ../*.hook
@@ -74,6 +69,8 @@ package_glib2-docs-git() {
pkgdesc="Documentation for GLib"
depends=()
optdepends=()
+ provides=(glib2-docs)
+ conflicts=(glib2-docs)
license+=(custom)
mkdir -p "$pkgdir/usr/share"