summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-06-11 11:45:18 -0400
committerSolomon Choina2018-06-11 11:45:18 -0400
commitb952065e804ad0edcf15e9ba20e237942b7d681c (patch)
tree6e34c80692826695e93450bfac2a70327b44a696
parent5f274144a17a707e0a578c5189d748998947426b (diff)
downloadaur-b952065e804ad0edcf15e9ba20e237942b7d681c.tar.gz
moving back to autotools because gimp requires libtool as of current
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec8ae836a237..67b041730867 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = glib2-git
pkgdesc = Low Level Core Library
- pkgver = 2.57.1.203.g8bbc38b49
+ pkgver = 2.57.1.212.g54498aa7a
pkgrel = 1
url = https://wiki.gnome.org/Projects/GLib
arch = x86_64
license = LGPL2.1
checkdepends = desktop-file-utils
- makedepends = meson
- makedepends = ninja
makedepends = gettext
makedepends = gtk-doc
makedepends = shared-mime-info
@@ -22,7 +20,7 @@ pkgbase = glib2-git
depends = zlib
optdepends = python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report
optdepends = libelf: gresource inspection tool
- provides = glib2=2.57.1.203.g8bbc38b49
+ provides = glib2=2.57.1.212.g54498aa7a
options = !emptydirs
source = git+https://gitlab.gnome.org/GNOME/glib.git
source = 0001-noisy-glib-compile-schemas.patch
diff --git a/PKGBUILD b/PKGBUILD
index 0c8751de0590..84393a32d65f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
pkgbase=glib2-git
_pkgame=glib2
pkgname=(glib2-git glib2-docs-git)
-pkgver=2.57.1.203.g8bbc38b49
+pkgver=2.57.1.212.g54498aa7a
pkgrel=1
pkgdesc="Low Level Core Library"
arch=('x86_64')
url="https://wiki.gnome.org/Projects/GLib"
license=(LGPL2.1)
depends=(pcre libffi libutil-linux zlib)
-makedepends=(meson ninja gettext gtk-doc shared-mime-info python libelf git util-linux dbus)
+makedepends=(gettext gtk-doc shared-mime-info python libelf git util-linux dbus)
checkdepends=(desktop-file-utils)
optdepends=('python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report'
'libelf: gresource inspection tool')
@@ -36,20 +36,25 @@ pkgver() {
prepare() {
cd $srcdir/glib
# Suppress noise from glib-compile-schemas.hook
- patch -Np1 -i ../0001-noisy-glib-compile-schemas.patch
+ patch -Np1 -i ../0001-noisy-glib-compile-schemas.patch
+ NOCONFIGURE=1 ./autogen.sh
}
build () {
local debug=minimum
- check_option debug y && debug=yes
+ check_option debug y && debug=yes
cd "$srcdir/glib"
- arch-meson build \
- -Dfam=false \
- -Dgtk_doc=true \
- -Dselinux=false
- ninja -C build
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --sysconfdir=/etc \
+ --with-pcre=system \
+ --enable-debug=$debug \
+ --enable-gtk-doc \
+ --disable-fam
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
}
#check() {internal_pcre
@@ -59,7 +64,7 @@ build () {
package_glib2-git() {
cd "$srcdir/glib"
- DESTDIR="$pkgdir" ninja -C build install
+ DESTDIR="$pkgdir" make install
mv "$pkgdir/usr/share/gtk-doc" "$srcdir"
install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 ../*.hook