summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordudemanguy2020-10-12 07:44:57 -0500
committerdudemanguy2020-10-12 07:44:57 -0500
commit5af3256e40380651f884ff8a70aeeda54ec83016 (patch)
tree567e0a7fd11f6a93fdb27135633af71175f7f049
parentff227ac7646f3ff25dfe1a95e7b8e51eb4337f64 (diff)
downloadaur-5af3256e40380651f884ff8a70aeeda54ec83016.tar.gz
2.66.1-2
-rw-r--r--.SRCINFO11
-rw-r--r--1683.patch102
-rw-r--r--PKGBUILD17
3 files changed, 122 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a34fd6ce5083..a7beeed0d724 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = glib2-patched-thumbnailer
pkgdesc = GLib2 patched with ahodesuka's thumbnailer patch.
- pkgver = 2.66.0
- pkgrel = 1
+ pkgver = 2.66.1
+ pkgrel = 2
url = https://gist.github.com/Dudemanguy/d199759b46a79782cc1b301649dec8a5
arch = x86_64
license = LGPL2.1
@@ -15,6 +15,7 @@ pkgbase = glib2-patched-thumbnailer
makedepends = util-linux
makedepends = meson
makedepends = dbus
+ makedepends = sysprof
depends = pcre
depends = libffi
depends = util-linux-libs
@@ -23,7 +24,7 @@ pkgbase = glib2-patched-thumbnailer
depends = libmount.so
optdepends = python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report
optdepends = libelf: gresource inspection tool
- provides = glib2=2.66.0
+ provides = glib2=2.66.1
provides = libgio-2.0.so
provides = libglib-2.0.so
provides = libgmodule-2.0.so
@@ -31,12 +32,14 @@ pkgbase = glib2-patched-thumbnailer
provides = libgthread-2.0.so
conflicts = glib2
options = !docs
- source = git+https://gitlab.gnome.org/GNOME/glib.git#commit=c2c12e42920d6e06c23c87398996827e53c1fc72
+ source = git+https://gitlab.gnome.org/GNOME/glib.git#commit=b2f8ba8a11482dc702a470e92552cbb97765dbc9
+ source = 1683.patch
source = noisy-glib-compile-schemas.diff
source = glib-compile-schemas.hook
source = gio-querymodules.hook
source = glib-thumbnailer.patch
sha256sums = SKIP
+ sha256sums = e1913090c7cdd4c7db12651858a8381be28ae61f19d5e5e02a33f4c7c74c926d
sha256sums = 81a4df0b638730cffb7fa263c04841f7ca6b9c9578ee5045db6f30ff0c3fc531
sha256sums = 64ae5597dda3cc160fc74be038dbe6267d41b525c0c35da9125fbf0de27f9b25
sha256sums = 557c88177f011ced17bdeac1af3f882b2ca33b386a866fdf900b35f927a2bbe8
diff --git a/1683.patch b/1683.patch
new file mode 100644
index 000000000000..c5ad4a3c0772
--- /dev/null
+++ b/1683.patch
@@ -0,0 +1,102 @@
+From b411f518b8dc7a99bad52884048436d991c89b77 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=D0=A0=D1=83=D1=81=D0=BB=D0=B0=D0=BD=20=D0=98=D0=B6=D0=B1?=
+ =?UTF-8?q?=D1=83=D0=BB=D0=B0=D1=82=D0=BE=D0=B2?= <lrn1986@gmail.com>
+Date: Mon, 5 Oct 2020 17:07:29 +0000
+Subject: [PATCH 1/2] Add a test for the 6-days-until-EOM bug
+
+---
+ glib/tests/gdatetime.c | 26 ++++++++++++++++++++++++++
+ 1 file changed, 26 insertions(+)
+
+diff --git a/glib/tests/gdatetime.c b/glib/tests/gdatetime.c
+index 52eec1e46..0731f01f2 100644
+--- a/glib/tests/gdatetime.c
++++ b/glib/tests/gdatetime.c
+@@ -2192,6 +2192,31 @@ test_z (void)
+ g_time_zone_unref (tz);
+ }
+
++static void
++test_6_days_util_end_of_the_month (void)
++{
++ GTimeZone *tz;
++ GDateTime *dt;
++ gchar *p;
++
++ g_test_bug ("https://gitlab.gnome.org/GNOME/glib/-/issues/2215");
++
++#ifdef G_OS_UNIX
++ tz = g_time_zone_new ("Europe/Paris");
++#elif defined (G_OS_WIN32)
++ tz = g_time_zone_new ("Romance Standard Time");
++#endif
++ dt = g_date_time_new (tz, 2020, 10, 5, 1, 1, 1);
++
++ p = g_date_time_format (dt, "%Y-%m-%d %H:%M:%S%z");
++ /* Incorrect output is "2020-10-05 01:01:01+0100" */
++ g_assert_cmpstr (p, ==, "2020-10-05 01:01:01+0200");
++ g_free (p);
++
++ g_date_time_unref (dt);
++ g_time_zone_unref (tz);
++}
++
+ static void
+ test_format_iso8601 (void)
+ {
+@@ -2785,6 +2810,7 @@ main (gint argc,
+ g_test_add_func ("/GDateTime/new_from_iso8601/2", test_GDateTime_new_from_iso8601_2);
+ g_test_add_func ("/GDateTime/new_full", test_GDateTime_new_full);
+ g_test_add_func ("/GDateTime/now", test_GDateTime_now);
++ g_test_add_func ("/GDateTime/test-6-days-util-end-of-the-month", test_6_days_util_end_of_the_month);
+ g_test_add_func ("/GDateTime/printf", test_GDateTime_printf);
+ g_test_add_func ("/GDateTime/non_utf8_printf", test_non_utf8_printf);
+ g_test_add_func ("/GDateTime/format_unrepresentable", test_format_unrepresentable);
+--
+GitLab
+
+
+From 4a120c2e2e0a26e1cd5ce7cb4ebe906ef6d588d3 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=D0=A0=D1=83=D1=81=D0=BB=D0=B0=D0=BD=20=D0=98=D0=B6=D0=B1?=
+ =?UTF-8?q?=D1=83=D0=BB=D0=B0=D1=82=D0=BE=D0=B2?= <lrn1986@gmail.com>
+Date: Mon, 5 Oct 2020 16:53:47 +0000
+Subject: [PATCH 2/2] Fix the 6-days-until-the-end-of-the-month bug
+
+The addition causes the date to shift
+forward into 1st of the next month, because a 0-based offset
+is compared to be "more than" the days in the month instead of "more than
+or equal to".
+
+This is triggered by corner-cases where transition date is 6 days
+off the end of the month and our calculations put it at N+1th day of the
+month (where N is the number of days in the month). The subtraction should
+be triggered to move the date back a week, putting it 6 days off the end;
+for example, October 25 for CET DST transition; but due to incorrect comparison
+the date isn't shifted back, we add 31 days to October 1st and end up
+at November 1st).
+
+Fixes issue #2215.
+---
+ glib/gtimezone.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/glib/gtimezone.c b/glib/gtimezone.c
+index ef67ec50b..0de5c92a3 100644
+--- a/glib/gtimezone.c
++++ b/glib/gtimezone.c
+@@ -1041,7 +1041,11 @@ find_relative_date (TimeZoneDate *buffer)
+ /* week is 1 <= w <= 5, we need 0-based */
+ days = 7 * (buffer->week - 1) + wday - first_wday;
+
+- while (days > days_in_month)
++ /* "days" is a 0-based offset from the 1st of the month.
++ * Adding days == days_in_month would bring us into the next month,
++ * hence the ">=" instead of just ">".
++ */
++ while (days >= days_in_month)
+ days -= 7;
+
+ g_date_add_days (&date, days);
+--
+GitLab
+
diff --git a/PKGBUILD b/PKGBUILD
index c77f3d308102..e928f94c232c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=glib2-patched-thumbnailer
-pkgver=2.66.0
-pkgrel=1
+pkgver=2.66.1
+pkgrel=2
pkgdesc="GLib2 patched with ahodesuka's thumbnailer patch."
url="https://gist.github.com/Dudemanguy/d199759b46a79782cc1b301649dec8a5"
arch=(x86_64)
@@ -14,19 +14,21 @@ provides=(glib2=$pkgver libgio-2.0.so libglib-2.0.so libgmodule-2.0.so
conflicts=('glib2')
depends=(pcre libffi util-linux-libs zlib tumbler libmount.so)
makedepends=(gettext gtk-doc shared-mime-info python libelf git util-linux
- meson dbus)
+ meson dbus sysprof)
checkdepends=(desktop-file-utils)
optdepends=('python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report'
'libelf: gresource inspection tool')
options=('!docs')
license=(LGPL2.1)
-_commit=c2c12e42920d6e06c23c87398996827e53c1fc72 # tags/2.66.0^0
+_commit=b2f8ba8a11482dc702a470e92552cbb97765dbc9 # tags/2.66.1^0
source=("git+https://gitlab.gnome.org/GNOME/glib.git#commit=$_commit"
+ 1683.patch
noisy-glib-compile-schemas.diff
glib-compile-schemas.hook
gio-querymodules.hook
glib-thumbnailer.patch)
sha256sums=('SKIP'
+ 'e1913090c7cdd4c7db12651858a8381be28ae61f19d5e5e02a33f4c7c74c926d'
'81a4df0b638730cffb7fa263c04841f7ca6b9c9578ee5045db6f30ff0c3fc531'
'64ae5597dda3cc160fc74be038dbe6267d41b525c0c35da9125fbf0de27f9b25'
'557c88177f011ced17bdeac1af3f882b2ca33b386a866fdf900b35f927a2bbe8'
@@ -40,6 +42,9 @@ pkgver() {
prepare() {
cd glib
+ # https://gitlab.gnome.org/GNOME/glib/-/issues/2219
+ git apply -3 ../1683.patch
+
# Suppress noise from glib-compile-schemas.hook
git apply -3 ../noisy-glib-compile-schemas.diff
@@ -51,6 +56,7 @@ build() {
CFLAGS+=" -DG_DISABLE_CAST_CHECKS"
arch-meson glib build \
-D selinux=disabled \
+ -D sysprof=enabled \
-D man=true
meson compile -C build
}
@@ -64,6 +70,9 @@ package() {
DESTDIR="$pkgdir" meson install -C build
install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
+ # Avoid a dep on sysprof
+ sed -i 's/, sysprof-capture-4//' "$pkgdir"/usr/lib/pkgconfig/*.pc
+
export PYTHONHASHSEED=0
python -m compileall -d /usr/share/glib-2.0/codegen \
"$pkgdir/usr/share/glib-2.0/codegen"