summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaporeon2016-04-16 18:41:50 +1200
committerVaporeon2016-04-16 18:41:50 +1200
commitab6fe061f2bd4469fc25d3c6559864bc845cc5e8 (patch)
tree2da77cd1dc4b5eedb141b58d6fb3ee914ed02ac1
parentb33d5c2075cfa7782230d4fb01de7db761feab72 (diff)
downloadaur-ab6fe061f2bd4469fc25d3c6559864bc845cc5e8.tar.gz
update 2.48.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--memleak.patch25
3 files changed, 8 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e5ec728633a..0b253dfd2e28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Dec 12 05:58:46 UTC 2015
+# Sat Apr 16 06:39:09 UTC 2016
pkgbase = glib2-patched-thumbnailer
pkgdesc = GLib2 patched with ahodesuka's thumbnailer patch.
- pkgver = 2.46.2
+ pkgver = 2.48.0
pkgrel = 1
url = http://gist.github.com/ahodesuka/49c1d0eea4b64f24c4c7
arch = i686
@@ -24,14 +24,12 @@ pkgbase = glib2-patched-thumbnailer
conflicts = glib2
options = !docs
options = !emptydirs
- source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.46/glib-2.46.2.tar.xz
+ source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.48/glib-2.48.0.tar.xz
source = revert-warn-glib-compile-schemas.patch
source = https://gist.githubusercontent.com/ahodesuka/49c1d0eea4b64f24c4c7/raw/d0edf118e1c27700300038c1d82b3ff775c0216b/glib-thumbnailer.patch
- source = memleak.patch
- sha256sums = 5031722e37036719c1a09163cc6cf7c326e4c4f1f1e074b433c156862bd733db
+ sha256sums = 744be6931ca914c68af98dc38ff6b0cf8381d65e335060faddfbf04c17147c34
sha256sums = 049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97
sha256sums = 1a4673380fbdf8e8e5de3367089de6c97025633e54010575de63c5ab6c8a044d
- sha256sums = 8337eeba4a32133d41575c8338fca32ac6a867e6e4a4e021355fcdeb606420a6
pkgname = glib2-patched-thumbnailer
diff --git a/PKGBUILD b/PKGBUILD
index 6aed1731c671..d5607f2b2915 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=glib2-patched-thumbnailer
pkgname=glib2-patched-thumbnailer
-pkgver=2.46.2
+pkgver=2.48.0
_patchver=d0edf118e1c27700300038c1d82b3ff775c0216b
pkgrel=1
pkgdesc="GLib2 patched with ahodesuka's thumbnailer patch."
@@ -19,17 +19,14 @@ options=('!docs' '!emptydirs')
license=('LGPL')
source=(http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver:0:4}/glib-$pkgver.tar.xz
revert-warn-glib-compile-schemas.patch
- https://gist.githubusercontent.com/ahodesuka/49c1d0eea4b64f24c4c7/raw/$_patchver/glib-thumbnailer.patch
- memleak.patch)
-sha256sums=('5031722e37036719c1a09163cc6cf7c326e4c4f1f1e074b433c156862bd733db'
+ https://gist.githubusercontent.com/ahodesuka/49c1d0eea4b64f24c4c7/raw/$_patchver/glib-thumbnailer.patch)
+sha256sums=('744be6931ca914c68af98dc38ff6b0cf8381d65e335060faddfbf04c17147c34'
'049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97'
- '1a4673380fbdf8e8e5de3367089de6c97025633e54010575de63c5ab6c8a044d'
- '8337eeba4a32133d41575c8338fca32ac6a867e6e4a4e021355fcdeb606420a6')
+ '1a4673380fbdf8e8e5de3367089de6c97025633e54010575de63c5ab6c8a044d')
prepare() {
cd glib-$pkgver
patch -Rp1 -i ../revert-warn-glib-compile-schemas.patch
- patch -Np1 -i ../memleak.patch
patch -Np1 -i ${srcdir}/glib-thumbnailer.patch
}
diff --git a/memleak.patch b/memleak.patch
deleted file mode 100644
index 2b927a10138c..000000000000
--- a/memleak.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From db641e32920ee8b553ab6f2d318aafa156e4390c Mon Sep 17 00:00:00 2001
-From: Evangelos Foutras <evangelos@foutrelis.com>
-Date: Wed, 25 Nov 2015 23:29:18 +0200
-Subject: GDBusProxy: Fix a memory leak during initialization
-
-https://bugzilla.gnome.org/show_bug.cgi?id=758641
----
- gio/gdbusproxy.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/gio/gdbusproxy.c b/gio/gdbusproxy.c
-index 52a22fb..7b1140f 100644
---- a/gio/gdbusproxy.c
-+++ b/gio/gdbusproxy.c
-@@ -1720,6 +1720,7 @@ async_initable_init_second_finish (GAsyncInitable *initable,
- if (result != NULL)
- {
- process_get_all_reply (proxy, result);
-+ g_variant_unref (result);
- }
-
- proxy->priv->initialized = TRUE;
---
-cgit v0.11.2
-