summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2024-01-29 10:05:59 -0500
committerSolomon Choina2024-01-29 10:05:59 -0500
commit38a8b77c25db3def46e79c69f532595d59fc85d0 (patch)
tree4f3750bd68b26785fd9a25f1d240613bcd98c7aa
parentf7aeda8c88ba1d0988f47a12be7a576bd20661eb (diff)
downloadaur-glib2-selinux.tar.gz
updpkgver and license
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b41c1dee4a0..445d768ca88c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = glib2-selinux
pkgdesc = Low level core library
- pkgver = 2.78.1
+ pkgver = 2.79.1
pkgrel = 1
url = https://wiki.gnome.org/Projects/GLib
arch = x86_64
- license = LGPL
+ license = LGPL-2.1-or-later
makedepends = dbus
makedepends = gettext
makedepends = gtk-doc
@@ -23,16 +23,16 @@ pkgbase = glib2-selinux
depends = libsysprof-capture
options = debug
options = staticlibs
- source = git+https://gitlab.gnome.org/GNOME/glib.git#commit=21624e78f013ee8706483086e3086076d08fe242
+ source = git+https://gitlab.gnome.org/GNOME/glib.git#commit=143cb92c350bd1cb5411570600b8db2408c9d61d
source = git+https://gitlab.gnome.org/GNOME/gvdb.git
source = noisy-glib-compile-schemas.diff
source = glib-compile-schemas.hook
source = gio-querymodules.hook
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 81a4df0b638730cffb7fa263c04841f7ca6b9c9578ee5045db6f30ff0c3fc531
sha256sums = 64ae5597dda3cc160fc74be038dbe6267d41b525c0c35da9125fbf0de27f9b25
- sha256sums = 2a9f9b8235f48e3b7d0f6cfcbc76cd2116c45f28692cac4bd61074c495bd5eb7
- sha256sums = 92d08db5aa30bda276bc3d718e7ff9dd01dc40dcab45b359182dcc290054e24e
+ sha256sums = fbf49aef4b48f22c1abf40892e2e80b66409f83bd4a3ea155cd811b0c9c1e3b9
pkgname = glib2-selinux
depends = pcre
@@ -50,11 +50,11 @@ pkgname = glib2-selinux
provides = libgmodule-2.0.so
provides = libgobject-2.0.so
provides = libgthread-2.0.so
- provides = glib2=2.78.1
+ provides = glib2=2.79.1
conflicts = glib2
pkgname = glib2-selinux-docs
pkgdesc = Documentation for GLib
- license = LGPL
+ license = LGPL-2.1-or-later
license = custom
provides = glib2-docs
diff --git a/PKGBUILD b/PKGBUILD
index 090ea8d9e7c7..c19edd256734 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@
# Maintainer: Solomon Choina <shlomochoina@gmail.com>
pkgbase=glib2-selinux
pkgname=(glib2-selinux glib2-selinux-docs)
-pkgver=2.78.1
+pkgver=2.79.1
pkgrel=1
pkgdesc="Low level core library"
url="https://wiki.gnome.org/Projects/GLib"
-license=(LGPL)
+license=(LGPL-2.1-or-later)
arch=(x86_64)
depends=(pcre libffi util-linux-libs zlib libsysprof-capture)
makedepends=(dbus gettext gtk-doc shared-mime-info python libelf git util-linux
@@ -17,17 +17,17 @@ options=(
debug
staticlibs
)
-_commit=21624e78f013ee8706483086e3086076d08fe242 # tags/2.78.1^0
+_commit=143cb92c350bd1cb5411570600b8db2408c9d61d # tags/2.79.1^0
source=("git+https://gitlab.gnome.org/GNOME/glib.git#commit=$_commit"
"git+https://gitlab.gnome.org/GNOME/gvdb.git"
noisy-glib-compile-schemas.diff
glib-compile-schemas.hook gio-querymodules.hook
)
sha256sums=('SKIP'
+ 'SKIP'
'81a4df0b638730cffb7fa263c04841f7ca6b9c9578ee5045db6f30ff0c3fc531'
'64ae5597dda3cc160fc74be038dbe6267d41b525c0c35da9125fbf0de27f9b25'
- '2a9f9b8235f48e3b7d0f6cfcbc76cd2116c45f28692cac4bd61074c495bd5eb7'
- '92d08db5aa30bda276bc3d718e7ff9dd01dc40dcab45b359182dcc290054e24e')
+ 'fbf49aef4b48f22c1abf40892e2e80b66409f83bd4a3ea155cd811b0c9c1e3b9')
pkgver() {
cd glib
@@ -50,9 +50,10 @@ build() {
CFLAGS+=" -DG_DISABLE_CAST_CHECKS"
local meson_options=(
--default-library both
+ -D documentation=true
-D glib_debug=disabled
- -D gtk_doc=true
- -D man=true
+ -D gtk_doc=enabled
+ -D man-pages=enabled
-D selinux=enabled
-D sysprof=enabled
)