summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergej Pupykin2015-06-13 00:48:29 +0300
committerSergej Pupykin2015-06-13 00:48:29 +0300
commit06bcacb5a71435137b74ec7bf82b36c377d36d62 (patch)
tree960484794218b542c27165ccf0d4e32affd9e946
downloadaur-06bcacb5a71435137b74ec7bf82b36c377d36d62.tar.gz
migrate to aur4
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD40
-rw-r--r--revert-warn-glib-compile-schemas.patch33
3 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e047b4845c5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = glib2-static
+ pkgdesc = Common C routines used by GTK+ and other libs
+ pkgver = 2.44.0
+ pkgrel = 1
+ url = http://www.gtk.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = pkg-config
+ makedepends = python2
+ makedepends = libxslt
+ makedepends = docbook-xml
+ makedepends = pcre
+ makedepends = libffi
+ makedepends = elfutils
+ depends = pcre
+ depends = libffi
+ depends = glib2
+ optdepends = python2: for gdbus-codegen and gtester-report
+ optdepends = elfutils: gresource inspection tool
+ options = !docs
+ options = !libtool
+ options = !emptydirs
+ options = staticlibs
+ source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.44/glib-2.44.0.tar.xz
+ source = revert-warn-glib-compile-schemas.patch
+ sha256sums = f2d362b106a08fa801770d41829a06fcfe287a00421018869eebf5efc796f5b9
+ sha256sums = 049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97
+
+pkgname = glib2-static
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9c04c236477
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+pkgname=glib2-static
+pkgver=2.44.0
+pkgrel=1
+pkgdesc="Common C routines used by GTK+ and other libs"
+url="http://www.gtk.org/"
+arch=(i686 x86_64)
+depends=('pcre' 'libffi' "glib2")
+makedepends=('pkg-config' 'python2' 'libxslt' 'docbook-xml' 'pcre' 'libffi' 'elfutils')
+optdepends=('python2: for gdbus-codegen and gtester-report'
+ 'elfutils: gresource inspection tool')
+options=('!docs' '!libtool' '!emptydirs' 'staticlibs')
+license=('LGPL')
+source=(http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver%.*}/glib-$pkgver.tar.xz
+ revert-warn-glib-compile-schemas.patch)
+sha256sums=('f2d362b106a08fa801770d41829a06fcfe287a00421018869eebf5efc796f5b9'
+ '049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97')
+
+prepare() {
+ cd glib-$pkgver
+ patch -Rp1 -i ../revert-warn-glib-compile-schemas.patch
+}
+
+build() {
+ cd glib-$pkgver
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr --libdir=/usr/lib \
+ --sysconfdir=/etc \
+ --with-pcre=system \
+ --disable-fam --enable-static
+ make
+}
+
+package() {
+ cd glib-$pkgver
+ make completiondir=/usr/share/bash-completion/completions DESTDIR="$pkgdir" install
+ for _i in "$pkgdir/usr/share/bash-completion/completions/"*; do
+ chmod -x "$_i"
+ done
+ # Our gdb does not ship the required python modules, so remove it
+ rm -rf "$pkgdir/usr/"{bin,include,share,lib/glib-2.0,lib/pkgconfig} $pkgdir/usr/lib/*.so*
+}
diff --git a/revert-warn-glib-compile-schemas.patch b/revert-warn-glib-compile-schemas.patch
new file mode 100644
index 000000000000..75b05103cd02
--- /dev/null
+++ b/revert-warn-glib-compile-schemas.patch
@@ -0,0 +1,33 @@
+From 6560b37450cd19c4a7c7b690e279fe97b7bfdcaa Mon Sep 17 00:00:00 2001
+From: Ryan Lortie <desrt@desrt.ca>
+Date: Thu, 12 Apr 2012 23:55:34 +0000
+Subject: glib-compile-schemas: warn about bad dconf paths
+
+For quite some time the recommended usage of GSettings and dconf has
+been to use paths like /org/gnome/example/. Use of /apps/ has spilled
+over from GConf and is continuing to make its way into a number of
+applications as they port.
+
+glib-compile-schemas will now warn about these types of paths being
+used. This generates a lot of noise, but hopefully it will reduce the
+number of ported applications making this mistake.
+---
+diff --git a/gio/glib-compile-schemas.c b/gio/glib-compile-schemas.c
+index cf02389..27d0181 100644
+--- a/gio/glib-compile-schemas.c
++++ b/gio/glib-compile-schemas.c
+@@ -1204,6 +1204,12 @@ parse_state_start_schema (ParseState *state,
+ return;
+ }
+
++ if (path && (g_str_has_prefix (path, "/apps/") ||
++ g_str_has_prefix (path, "/desktop/") ||
++ g_str_has_prefix (path, "/system/")))
++ g_printerr ("warning: Schema '%s' has path '%s'. Paths starting with "
++ "'/apps/', '/desktop/' or '/system/' are deprecated.\n", id, path);
++
+ state->schema_state = schema_state_new (path, gettext_domain,
+ extends, extends_name, list_of);
+
+--
+cgit v0.9.0.2