summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2018-04-22 18:04:31 -0400
committerEli Schwartz2018-04-22 18:04:31 -0400
commit8eb1a85a85ee618a3697f5a6306620651e34f05c (patch)
treebd70a2595a1cd6875934987695e0c0633b59a9c7
parent87518c5e40a34bea517f1e2bb576860f7ecf31ba (diff)
downloadaur-8eb1a85a85ee618a3697f5a6306620651e34f05c.tar.gz
upgpkg: glibc-git 2.27.r346.g573963e32f-1
minor cleanup, disable nsl/rpc in accordance with core package. This is tied to the testing repositories which split out libnsl into a separate package.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD22
2 files changed, 10 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02b635fa5d50..00abc101c2a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = glibc-git
pkgdesc = GNU C Library, from git
- pkgver = 2.27.r209.gc553cd6f7e
+ pkgver = 2.27.r346.g573963e32f
pkgrel = 1
url = https://www.gnu.org/software/libc/
install = glibc-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 19c74428cbe4..bf77f6817cd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
pkgname=glibc-git
-pkgver=2.27.r209.gc553cd6f7e
+pkgver=2.27.r346.g573963e32f
pkgrel=1
pkgdesc='GNU C Library, from git'
arch=('i686' 'x86_64')
@@ -68,8 +68,6 @@ build() {
--enable-bind-now \
--enable-lock-elision \
--enable-multi-arch \
- --enable-obsolete-nsl \
- --enable-obsolete-rpc \
--enable-stack-protector=strong \
--enable-stackguard-randomization \
--disable-profile \
@@ -116,16 +114,14 @@ package() {
# I use 2> /dev/null for all of these due to many false-positives as it
# attempts to strip scripts or other unstrippable files.
find "$pkgdir"/usr/bin -type f -executable -exec strip $STRIP_BINARIES {} + 2> /dev/null || true
-
- # Do not strip these for gdb and valgrind functionality, but strip the
- # rest.
- find "$pkgdir"/usr/lib ! -name 'ld-*.so' \
- ! -name 'libc-*.so' \
- ! -name 'libpthread-*.so' \
- ! -name 'libthread_db-*.so' \
- -name '*-*.so' -type f -exec strip $STRIP_SHARED {} + 2> /dev/null || true
-
- # Strip the remaining static libraries.
find "$pkgdir"/usr/lib -name '*.a' -type f -exec strip $STRIP_STATIC {} + 2> /dev/null || true
+
+ # Do not strip these for gdb and valgrind functionality.
+ find "$pkgdir"/usr/lib \
+ -not -name 'ld-*.so' \
+ -not -name 'libc-*.so' \
+ -not -name 'libpthread-*.so' \
+ -not -name 'libthread_db-*.so' \
+ -name '*-*.so' -type f -exec strip $STRIP_SHARED {} + 2> /dev/null || true
fi
}